Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#33574 - depends and makedepends logic

Attached to Project: Pacman
Opened by Maxime Gauduin (Alucryd) - Saturday, 26 January 2013, 14:23 GMT
Last edited by Ionut Biru (wonder) - Saturday, 26 January 2013, 15:20 GMT
Task Type Feature Request
Category makepkg
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 4.0.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Currently, packages in the depends array are considered makedepends too. While there are packages needed at build time only, the reverse is also true, some packages are only needed at runtime. Requiring and installing the runtime depends at build time causes problem for packages with hard dependencies on versions, like the NVIDIA drivers suite.
Say you want to update the following: nvidia-beta, nvidia-utils-beta, lb32-nvidia-utils-beta; you start by building nvidia-beta, which requires nvidia-utils-beta at the same version, however lib32-nvidia-utils-beta requires nvidia-utils-beta at the previous version. Dead end, same issue no matter where you start. You have to remove all the suite to install the new, or remove the nvidia-utils-beta with -Rdd beforehand.

While there are but a few packages concerned, making depends and makedepends independent would make more sense and be more correct.
This task depends upon

Closed by  Ionut Biru (wonder)
Saturday, 26 January 2013, 15:20 GMT
Reason for closing:  Not a bug
Comment by Ionut Biru (wonder) - Saturday, 26 January 2013, 15:08 GMT
what about start building your packages using nvidia-utils-beta and then nvidia-beta.
Comment by Maxime Gauduin (Alucryd) - Saturday, 26 January 2013, 15:18 GMT
Same story, lib32-nvidia-utils-beta and nvidia-beta requires the previous version of nvidia-utils-beta, so pacman won't replace it.
Comment by Ionut Biru (wonder) - Saturday, 26 January 2013, 15:20 GMT
stuff happen when you use unsupported builds instead of using binary packages that exists into a repo.

i don't see any reason to have this bug opened, since is not a bug.
Comment by Maxime Gauduin (Alucryd) - Saturday, 26 January 2013, 15:22 GMT
Absolutely, I understand a few packages are probably not worth all the trouble changing this logic will cause, but I thought I'd share the issue here since packages like nvidia-total are not allowed on the AUR.
Comment by Allan McRae (Allan) - Saturday, 26 January 2013, 22:17 GMT
FYI, this has been discussed before - I found this https://bugs.archlinux.org/task/2891 but there are more.

Loading...