Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#33516 - [linux] 3.7.x - 3.9.x Suspend causes lock up on Thinkpad X60

Attached to Project: Arch Linux
Opened by Gabriel Fornaeus (dunz0r) - Tuesday, 22 January 2013, 13:43 GMT
Last edited by Tobias Powalowski (tpowa) - Tuesday, 06 August 2013, 14:04 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture i686
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No



Whenever my Thinkpad X60 goes in to suspend it can not wake up from it. This is regardless if I am running X or not. The machine can not be woken up by any keypresses and does not respond to the three finger salute, a hard reset is needed.

I tried upgrading my kernel to 3.7.4-1 from testing, no difference.

Additional info:
linux-3.7.4-1, systemd-197-4, pm-utils-1.4.1-5
Attached is pm-suspend which only claims that suspend succeded.

Steps to reproduce:
Run pm-suspend.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Tuesday, 06 August 2013, 14:04 GMT
Reason for closing:  No response
Comment by Gabriel Fornaeus (dunz0r) - Tuesday, 22 January 2013, 13:44 GMT
Lspci output added.
   lspci (2 KiB)
Comment by Gabriel Fornaeus (dunz0r) - Wednesday, 23 January 2013, 09:24 GMT
I can add that downgrading to 3.6.11 fixes this issue.
Comment by Ryan Egesdahl (deriamis) - Thursday, 24 January 2013, 11:16 GMT
The kvm_intel module has been implicated in earlier kernel releases ( ), and I see you have it loaded. Have you tried adding it to SUSPEND_MODULES in /etc/pm/config.d/modules yet?
Comment by Gabriel Fornaeus (dunz0r) - Thursday, 24 January 2013, 22:23 GMT
Did just now, no change. I also tried removing the module with modprobe -r, no change. Also tried with the VT-option turned both on and off. No difference.

Attached lsmod too.
   lsmod (3.2 KiB)
Comment by Jan (medhefgo) - Monday, 28 January 2013, 16:28 GMT
Try finding the culprit with resume tracing (be The feature should be enabled in the 3.7.5 kernel in testing.
Comment by Safi ud Din Khan (safiuddinkhan) - Tuesday, 05 February 2013, 01:40 GMT
i had the similar problem on my dell n5050 laptop . i tried everything and suspected stuff from laptop-mode to vrbox but in the end it turned out the that it was intel graphics driver i915 fault .

this kernel parameter solved it for me "i915_enable_rc6=0"
Comment by Safi ud Din Khan (safiuddinkhan) - Tuesday, 05 February 2013, 01:44 GMT
what i have understood is that in 90% of the cases of faulty suspend and hibernate gpu is the main fault
try running your system with "nomodeset" if everything works well using this parameter then it means it is defiantly the gpu which is causing all the problem
Comment by Gabriel Fornaeus (dunz0r) - Wednesday, 06 February 2013, 19:46 GMT
I tried with both of the boot parameters, no change. Still the same behaviour.
Comment by Gabriel Fornaeus (dunz0r) - Wednesday, 06 February 2013, 21:10 GMT
Doing the s2ram-tracing gives me "pci_express 0000:00:1c.2:pcie08: hash matches".
Comment by Gabriel Fornaeus (dunz0r) - Thursday, 07 February 2013, 12:27 GMT
00:1c.2 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 3 (rev 02)

Is what's on that port. I'm not sure my laptop uses said ports for anything, could I disable it?
Comment by Tobias Powalowski (tpowa) - Wednesday, 27 February 2013, 11:26 GMT
Status on 3.8?
Comment by Ivaylo Petrov (infestdead) - Wednesday, 20 March 2013, 19:57 GMT
Same issue on ThinkPad X60, with latest kernel 3.8.3-2, tried booting with linux-lts - suspend works perfectly - no other change made whatsoever.
Comment by Gabriel Fornaeus (dunz0r) - Tuesday, 26 March 2013, 16:10 GMT
That's because linux-LTS is Linux 3.0.70. This issue appears after 3.6.11.

Still the same behaviour with 3.8.4-1
Comment by Tobias Powalowski (tpowa) - Thursday, 23 May 2013, 19:47 GMT
Status on 3.9?
Comment by Orim Kurowe (orim) - Friday, 24 May 2013, 15:54 GMT
I have a Samsung X20 Notebook and the same problems. It started with 3.7.* and is still not working with 3.9.3, LTS works fine. I think 3.6.11 actually worked for me. I can check if that helps...
Comment by Jonas Heinrich (onny) - Thursday, 04 July 2013, 18:32 GMT
This might be a duplicate of my bug, could you please test the attached patch: suspendfix_minimal_works.patch?
Comment by Tobias Powalowski (tpowa) - Tuesday, 30 July 2013, 10:30 GMT
Status on 3.10.x?