Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#33507 - [bash] 4.2.042-2 turns system unusable

Attached to Project: Arch Linux
Opened by Heinrich Siebmanns (Harvey) - Tuesday, 22 January 2013, 08:33 GMT
Last edited by Allan McRae (Allan) - Tuesday, 22 January 2013, 11:53 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Allan McRae (Allan)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Todays update from bash-4.2.042-1 to bash-4.2.042-2 turns my sytem unusable. No login Manager (KDM) anymore and trying to use tty login I could give username and password then the shell would end itself and just show the login prompt again. Logging in via ssh failed with

harvey@obelix ~ $ ssh root@gutemine
Last login: Tue Jan 22 09:09:55 2013 from
/bin/bash: Exec format error
Connection to gutemine closed.

I started with a Install disk and as you wold guess I couldn't chroot into the installation. I had to manually overwrite the file from bash-4.2.042-2 with the files from bash-4.2.042-1. After a reboot all was well again.
This task depends upon

Closed by  Allan McRae (Allan)
Tuesday, 22 January 2013, 11:53 GMT
Reason for closing:  Works for me
Comment by phanisvara das (phani00) - Tuesday, 22 January 2013, 09:20 GMT
hm, everything works fine on my system after the same update was applied.
Comment by Allan McRae (Allan) - Tuesday, 22 January 2013, 11:05 GMT
Can not replicate here... so I will need more information. Does installing the update again cause the same issue?
Comment by Heinrich Siebmanns (Harvey) - Tuesday, 22 January 2013, 11:50 GMT
While biting my nails I did another try after deleting the original download from /var/cache/pacman/pkg. This time it did succeed. Must have been a broken download. Bug can be closed. Sorry for the noise.