Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33496 - [vlc] Crashes out with Seg faults.

Attached to Project: Arch Linux
Opened by Tom Brennan (t0mm13b) - Monday, 21 January 2013, 19:19 GMT
Last edited by Giovanni Scafora (giovanni) - Monday, 11 March 2013, 17:43 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Giovanni Scafora (giovanni)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

VLC 2.0.5 dumps with segmentation fault

Log reported from Kernel version:

Linux darkstar 3.6.11-1-ARCH #1 SMP PREEMPT Tue Dec 18 08:57:15 CET 2012 x86_64 GNU/Linux

Jan 19 01:02:03 darkstar kernel: [ 7933.164815] vlc[2278]: segfault at 0 ip b6ed3734 sp b269a5e0 error 4 in libdvdnav.so.4.1.2[b6ecc000+14000]
Jan 20 02:47:29 darkstar kernel: [100658.546270] vlc[8821]: segfault at 0 ip b6e65734 sp b262c5e0 error 4 in libdvdnav.so.4.1.2[b6e5e000+14000]
Jan 21 02:21:47 darkstar kernel: [185516.497929] vlc[12077]: segfault at 0 ip b6e24734 sp b25eb5e0 error 4 in libdvdnav.so.4.1.2[b6e1d000+14000]

Under gdb trace:
$ gdb vlc
GNU gdb (GDB) 7.5.1
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/vlc...(no debugging symbols found)...done.
(gdb) set logging file vlctrace.log
(gdb) set logging on
Copying output to vlctrace.log.
(gdb) run
Starting program: /usr/bin/vlc
warning: Could not load shared library symbols for linux-gate.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
VLC media player 2.0.5 Twoflower (revision 2.0.5-0-g1661b7d)
[New Thread 0xb76efb40 (LWP 13305)]
[0x804d920] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Traceback (most recent call last):
File "/usr/share/gdb/auto-load/usr/lib/libgobject-2.0.so.0.3400.3-gdb.py", line 9, in <module>
from gobject import register
File "/usr/share/glib-2.0/gdb/gobject.py", line 3, in <module>
import gdb.backtrace
ImportError: No module named backtrace
[New Thread 0xb6c8cb40 (LWP 13306)]
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
[New Thread 0xb2f68b40 (LWP 13307)]
[Thread 0xb2f68b40 (LWP 13307) exited]
[New Thread 0xb2ee7b40 (LWP 13308)]
libdvdnav: Using dvdnav version 4.2.0
libdvdread: Using libdvdcss version 1.2.12 for DVD access
libdvdread: Attempting to use device /dev/loop0 mounted on /media for CSS authentication
libdvdread: Could not open /dev/loop0 with libdvdcss.
libdvdread: Can't open /dev/loop0 for reading
libdvdread: Device /dev/loop0 inaccessible, CSS authentication not available.
libdvdnav: Can't read name block. Probably not a DVD-ROM device.
libdvdnav: Unable to find map file '/home/t0mm13b/.dvdnav/.map'
libdvdnav: DVD disk reports itself with Region mask 0x00fd0000. Regions: 2

*** libdvdread: CHECK_VALUE failed in ifo_read.c:915 ***
*** for pgc->cell_playback_offset != 0 ***


*** libdvdread: CHECK_VALUE failed in ifo_read.c:915 ***
*** for pgc->cell_playback_offset != 0 ***


*** libdvdread: CHECK_VALUE failed in ifo_read.c:915 ***
*** for pgc->cell_playback_offset != 0 ***


Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb2ee7b40 (LWP 13308)]
0xb771f734 in dvdnav_describe_title_chapters () from /usr/lib/libdvdnav.so.4
(gdb) bt
#0 0xb771f734 in dvdnav_describe_title_chapters () from /usr/lib/libdvdnav.so.4
#1 0xb7fc1856 in ?? () from /usr/lib/vlc/plugins/access/libdvdnav_plugin.so
#2 0xb7f2d580 in ?? () from /usr/lib/libvlccore.so.5
#3 0xb7f2dcc3 in vlc_module_load () from /usr/lib/libvlccore.so.5
#4 0xb7f2e1e2 in module_need () from /usr/lib/libvlccore.so.5
#5 0xb7edb17a in ?? () from /usr/lib/libvlccore.so.5
#6 0xb7ee979d in ?? () from /usr/lib/libvlccore.so.5
#7 0xb7eea960 in ?? () from /usr/lib/libvlccore.so.5
#8 0xb7eeebdc in ?? () from /usr/lib/libvlccore.so.5
#9 0xb7e84d08 in start_thread () from /usr/lib/libpthread.so.0
#10 0xb7db8cce in clone () from /usr/lib/libc.so.6
(gdb) set logging off
Done logging to vlctrace.log.
(gdb) quit
A debugging session is active.

Inferior 1 [process 13297] will be killed.

Quit anyway? (y or n)
Please answer y or n.
A debugging session is active.

Inferior 1 [process 13297] will be killed.

Quit anyway? (y or n) y


Mount an ISO as loopback, i.e. sudo mount -o loop DVD.iso /media
Launch VLC and point it to /media by selecting open Disc from menu.
The crash occurs.
This task depends upon

Closed by  Giovanni Scafora (giovanni)
Monday, 11 March 2013, 17:43 GMT
Reason for closing:  Not a bug
Additional comments about closing:  libdvdnav robustness bug. Update or fix libdvdnav.
Comment by Jelle van der Waa (jelly) - Tuesday, 22 January 2013, 20:46 GMT
Please report the bug upstream
Comment by Tom Brennan (t0mm13b) - Tuesday, 22 January 2013, 20:50 GMT
Hi Jelly,

Thanks for looking at this, do I need to do anything at this point?

Cheers :)
Comment by Mathias Rohnstock (drmonty) - Wednesday, 23 January 2013, 07:27 GMT
see http://wiki.videolan.org/Report_bugs and feel free to report the bug to their trac, forum or by email.
Comment by Tom Brennan (t0mm13b) - Wednesday, 23 January 2013, 15:29 GMT
Have reported on VLC's issue tracker (https://trac.videolan.org/vlc/ticket/8077)

-Cheers :)

Loading...