Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33471 - [gparted] gparted-pkexec fail to start from menu, but works in terminal

Attached to Project: Arch Linux
Opened by lainme (lainme) - Sunday, 20 January 2013, 13:24 GMT
Last edited by Giovanni Scafora (giovanni) - Sunday, 12 January 2014, 13:43 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Giovanni Scafora (giovanni)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

When click the gparted menu item, an authentication box appears, but quickly show "Sorry, that didn't work, please try agian." and disappear, no matter what I did.

I found that gparted is invoked by gparted-pkexec. But when I run gparted-pkexec from terminal, everything works fine without any warning or error message.

The desktop environment I am using is gnome-shell. And the polkit-gnome package is already installed.

Additional info:

* kernel version: 3.6.11-1
* gnome-shell version: 3.6.2
* gparted version: 0.14.1-1

Steps to reproduce:

* Install gparted
* Run gparted from menu
This task depends upon

Closed by  Giovanni Scafora (giovanni)
Sunday, 12 January 2014, 13:43 GMT
Reason for closing:  Not a bug
Comment by lainme (lainme) - Monday, 21 January 2013, 15:40 GMT
Update. It seems that if I click the menu item in gnome-shell, there is no problem. But if I search "gparted" in gnome-shell, and press enter, the authentation will fail.
Comment by Vasili (3point2) - Wednesday, 23 January 2013, 22:12 GMT
same here. i installed gparted and clicking on the menu item does nothing (i'm using XFCE 4.10). running gparted-pkexec from a terminal works fine.
Comment by Adam Young (atyoung) - Thursday, 31 January 2013, 07:08 GMT
I have seen this one as well, latest builds of both gparted and gnome-shell.
Comment by tsester (tsester) - Saturday, 09 February 2013, 14:25 GMT
Comment by alex (kabolt) - Thursday, 14 February 2013, 15:18 GMT
have also this problem, but also with other programs (even my own). It's the pkexec helper.
Comment by Balló György (City-busz) - Wednesday, 06 March 2013, 07:56 GMT
It looks like it's a bug in gnome-shell. Please report it to upstream developers:
https://bugzilla.gnome.org/browse.cgi?product=gnome-shell
Comment by lainme (lainme) - Wednesday, 06 March 2013, 08:05 GMT
I found a existing upstream bug report: https://bugzilla.gnome.org/show_bug.cgi?id=683179 . Seems related to pkexec
Comment by Mantas Mikulėnas (grawity) - Wednesday, 06 March 2013, 08:44 GMT
lainme:

> It seems that if I click the menu item in gnome-shell, there is no problem. But if I search "gparted" in gnome-shell, and press enter, the authentation will fail.

This was fixed in 3.7, see https://bugzilla.gnome.org/show_bug.cgi?id=692937#c3

Vasili:

> same here. i installed gparted and clicking on the menu item does nothing

"does nothing" is not the same as "authentication fails"...
Comment by Vasili (3point2) - Saturday, 09 March 2013, 13:33 GMT
I discovered the solution to this when installing unetbootin using pacman. A mandatory dependency for unetbootin is polkit-gnome. One of the post-install messages i got (from polkit-gnome) was

installed polkit-gnome (0.105-1)
If you use a lightweight windowmanager, remember to run
/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 to enable
graphical authentication, which may be needed for pkexec to work.

Adding '/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 &' to my .xinitrc solved the problem for gparted too.

On checking the dependency list for gparted, I noticed 'polkit-gnome: to run gparted directly from menu' under the list of optional dependencies.

For unetbootin, the dependency is mandatory.

I don't think having gnome-polkit listed optional dependency for gparted in order for the menu item to work is a great idea, but on the other hand making a non-essential package mandatory isn't that great either. Maybe someone else can think of a better solution, or perhaps this bug should just be closed.
Comment by lainme (lainme) - Saturday, 09 March 2013, 13:39 GMT
Thanks Mantas M., I think the issue can be closed.
Comment by sb56637 (sb56637) - Wednesday, 13 November 2013, 17:53 GMT
On Gnome 3.8.4 I frequently run into problems with the Gnome Shell password prompt. It repeatedly rejects my password, but then after a while it starts accepting it. It is very random and hard to pin down. Sometimes it rejects the first time and accepts it the second time. Sometimes on the third time. Occasionally it works on the first try. Sometimes it just keeps rejecting it. (Yes, I am typing my password correctly.) I usually open programs by searching applications menu and hitting enter, if that makes any difference.

Loading...