Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33463 - [cairo] 1.12.10 breaks Thunar's icons and thumbnails

Attached to Project: Arch Linux
Opened by A. Núñez (megadriver) - Saturday, 19 January 2013, 17:48 GMT
Last edited by Andreas Radke (AndyRTR) - Friday, 01 February 2013, 14:30 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Description:

Cairo 1.12.10 from testing seems to corrupt Thunar's icons and thumbnails.

Additional info:

See this thread for a more detailed description of the problem and a screenshot:
https://bbs.archlinux.org/viewtopic.php?id=156457

Steps to reproduce:

Just use Thunar with Cairo 1.12.10.
Downgrading to 1.12.8 (currently in extra) solved this problem for me.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Friday, 01 February 2013, 14:30 GMT
Reason for closing:  Fixed
Comment by Andreas Radke (AndyRTR) - Saturday, 19 January 2013, 18:01 GMT
Usually cairo triggers bugs in graphic card drivers. So what card do you use and what driver.
Comment by A. Núñez (megadriver) - Saturday, 19 January 2013, 21:20 GMT
I use a Nvidia card (9400GS, if that helps). I've tried with both nvidia and nouveau drivers. The results are the same.
Comment by Andreas Radke (AndyRTR) - Monday, 21 January 2013, 16:32 GMT
Please get in touch with upstream devs. File an upstream report.
Comment by Leonud Selivanov (bravebug) - Monday, 21 January 2013, 20:57 GMT
I have the same issue with xf86-video-ati
Downgraded to 1.12.8
It very annoying bug
Comment by Lukas Zavodny (LukynZ) - Tuesday, 22 January 2013, 01:13 GMT
I am really interested in explain, how the package with reported bug during testing enter the main tree.
Comment by Andreas Radke (AndyRTR) - Tuesday, 22 January 2013, 08:59 GMT
So far it's only a thunmbnail rendering issue in one single file manager. That's an upstream
bug not worth holding back all the fixes and improvements it brings to other people.

Please check what thunar does in a special way triggering this bug and bisect cairo commit and report it there.
Comment by Lukas Zavodny (LukynZ) - Tuesday, 22 January 2013, 09:22 GMT
No, it's not problem only in thunar, it's problem in nautilus too and probably in everything what use cairo for this task. And it's not only thumbnail problem, but all icons are broken and with this kind of bug the file manager is really unusable (if you aren't masochist). I don't know what important fixes it brings that we can exchange it with file managers usability, but I am really interested. However, everyone who install gnome,xfce at this days...or anything using cairo...will be very surprised what they see and probably run away test another distro.
Comment by David López (David López) - Tuesday, 22 January 2013, 12:19 GMT
I use lxde and openbox, and I'm suffering the same bug with pcmanfm. I'm afraid the bug is not related with thunar, I don't have it installed.
Comment by Jan de Groot (JGC) - Tuesday, 22 January 2013, 12:37 GMT
I can't reproduce this with xf86-video-intel, so it's probably something triggered in a driver. I suggest someone should bisect this bug using git to find out which commit introduced the broken thumbnailing.
Comment by David López (David López) - Tuesday, 22 January 2013, 12:47 GMT
I use xf86-video-intel 2.20.19-1 and suffer the problem.
Comment by phanisvara das (phani00) - Tuesday, 22 January 2013, 13:29 GMT
this also affects GIMP stable 2.8.2 from [extra], and 2.9 from git master. after the cairo upgrade, images zoomed larger than the automatically assigned size broke up into random tiles. tried changing & downgrading video drivers, switching to LTS kernel, but nothing helped. in the end, it was suggested on the arch users list to downgrade cairo, which solved the problem.

i wrote to the cairo mailing list, but no reply so far.
Comment by Evangelos Foutras (foutrelis) - Tuesday, 22 January 2013, 20:08 GMT Comment by A. Núñez (megadriver) - Wednesday, 23 January 2013, 10:24 GMT
While this get sorted out (or not) upstream, I've made an AUR package, patched to revert the two offending commits:
https://aur.archlinux.org/packages/cairo-patched/

It seems to work for me, but use it at your own risk. I'm not a "real programmer", so I might've screwed up somewhere...
Comment by Jason (Meyithi) - Wednesday, 23 January 2013, 11:15 GMT
Same with Nvidia beta's (313.18) - corruption when resizing images in gimp - http://ompldr.org/vaDZ0Nw
Comment by Thomas (radioactiveman) - Friday, 25 January 2013, 09:53 GMT Comment by Evangelos Foutras (foutrelis) - Friday, 25 January 2013, 09:55 GMT
Actually, it's not. cairo 1.12.10-3 in [testing] includes that commit but the issue remains.
Comment by phanisvara das (phani00) - Friday, 25 January 2013, 09:58 GMT
the issue doesn't remain, it came back with 1.12.10-3. i downloaded 1.12.10-2 from ARM, and that works fine.
[edit: oops, didn't notice the good version went into [extra] :\ ]
Comment by Jan de Groot (JGC) - Friday, 25 January 2013, 10:04 GMT
cairo 1.12.10-2 is still in extra, the new broken version with the upstream fix is in testing. You don't need to use ARM.
Comment by Andreas Radke (AndyRTR) - Friday, 25 January 2013, 11:29 GMT
If the testing pkg is broken again you should reopen the upstream report until it's truely fixed.
Comment by phanisvara das (phani00) - Friday, 25 January 2013, 11:54 GMT
that report doesn't talk about the GIMP at all. it's about evince, which shows symptoms of the same regression, apparently. i don't have that and wasn't planning on installing it. was hoping that, since it seems to be the same cause, the original reporter would find that the fix didn't work...
Comment by phanisvara das (phani00) - Friday, 25 January 2013, 11:59 GMT
re-opened the bug at https://bugs.freedesktop.org/show_bug.cgi?id=59635#c8, but am not sure how serious they're going to take this...
Comment by Andreas Radke (AndyRTR) - Friday, 25 January 2013, 12:00 GMT
To make sure: Are the icons broken again or only pdf rending or both?
Comment by Evangelos Foutras (foutrelis) - Friday, 25 January 2013, 12:06 GMT
I've only tested with Thunar and the icon rendering has the same glitches it had with 1.12.10-1; 1.12.10-2 was fine though.
Comment by phanisvara das (phani00) - Friday, 25 January 2013, 12:13 GMT
i have no problems rendering pdf -- in okular; the report talks about evince though. i don't have thunar either, but GIMP breaks with 1.12.10-1, works fine with 1.12.10-2, and breaks again in the same way with 1.12.10-3.
Comment by A. Núñez (megadriver) - Wednesday, 30 January 2013, 08:32 GMT
1.12.10-2 works perfectly for me.

With 1.12.10-3 I experience exactly the same problems I had with 1.12.10-1.
Comment by WorMzy Tykashi (WorMzy) - Wednesday, 30 January 2013, 12:28 GMT
The current package (1.12.10-2) causes Thunar, claws-mail, lxappearance, xfce4-notifyd, et al, to hang with a blank window; but only if I use gtk-engine-murrine. If I fall back on Raleigh, everything seems to work fine.

The current testing version (1.12.10-3) exhibits the same behaviour, as does the previous testing version (1.12.10-1).

Downgrading to 1.12.8-2 fixes the problem.
Comment by WorMzy Tykashi (WorMzy) - Wednesday, 30 January 2013, 12:31 GMT
Forgot to mention that this is affecting both a netbook with intel graphics (w/i915), and a desktop with ati graphics (w/radeon).
Comment by Jan de Groot (JGC) - Wednesday, 30 January 2013, 13:31 GMT
Your issue is totally unrelated to this bugreport. File a new bugreport upstream (search for existing one first) and provide them with detailed information. If you have some time, please use git bisect to find out which commit broke your murrine theme.
Comment by WorMzy Tykashi (WorMzy) - Wednesday, 30 January 2013, 14:36 GMT
You're right, and after further testing, the problem appears to be a single line in my .gtkrc-2.0. Sorry for the noise.
Comment by Andreas Radke (AndyRTR) - Thursday, 31 January 2013, 17:48 GMT
Please check 1.12.12 in testing that claims to fix the pdf issues and hopefully this is also the image rendering fix.
Comment by Evangelos Foutras (foutrelis) - Thursday, 31 January 2013, 18:37 GMT
cairo 1.12.12-1 does indeed seem to fix the thumbnail corruption issue in Thunar.

Someone else should try to confirm that the GIMP glitches are fixed as well. :)
Comment by phanisvara das (phani00) - Thursday, 31 January 2013, 18:49 GMT
yes, works fine with GIMP, too :)
Comment by A. Núñez (megadriver) - Thursday, 31 January 2013, 20:25 GMT
cairo 1.12.12 works for me, too!

Loading...