Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33421 - bitlbee still using OpenSSL rather than GnuTLS

Attached to Project: Arch Linux
Opened by Benjamin Cathey (becatlibra) - Wednesday, 16 January 2013, 18:17 GMT
Last edited by Dave Reisner (falconindy) - Thursday, 18 April 2013, 13:16 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Dave Reisner (falconindy)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

bitlbee still has issues with google (gtalk) which, according to the developer, should be resolved by switching from OpenSSL to GnuTLS. At this point, the latest version (3.2) has consistent issues with gtalk accounts which render the entire program unuseable. When a gtalk count is enabled (with SSL) after a period of time the entire bitlbee gateway stops responding and eventually seems to reset. Talked in the #bitlbee IRC room about this, GnuTLS is the recommended lib rather than OpenSSL and the supposed fix.

Steps to reproduce:
This task depends upon

Closed by  Dave Reisner (falconindy)
Thursday, 18 April 2013, 13:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  back to gnutls we go...
Comment by Dave Reisner (falconindy) - Wednesday, 16 January 2013, 18:56 GMT
This is not a bitlbee problem. If you still have this problem at the end of the week, we can talk about using gnutls instead. Keep in mind that we stopped using gnutls because of flaky problems just like this with gtalk/jabber so switching doesn't really solve anything.
Comment by Dave Reisner (falconindy) - Saturday, 19 January 2013, 17:33 GMT
Still a problem? I suspect it isn't...
Comment by Yardena Cohen (yardenac) - Thursday, 18 April 2013, 12:37 GMT
The bitlbee developer (wilmer on OFTC) has advised in very strong language that this package switch away from openssl for good. He cites the config script, which warns that distributing the binary package as-is "probably illegal": http://code.bitlbee.org/lh/bitlbee/view/head:/configure#L411

He's also talking about disabling openssl support altogether if the channel keeps getting complaints stemming from this. I and several other users all came with the same problem and all of us had our problems magically go away when recompiling with gnutls.

I understand that there was some churn with this back in 2011, but upstream seems to view it as a problem with only one solution, and the Arch way usually means siding with upstream, right?
Comment by Dave Reisner (falconindy) - Thursday, 18 April 2013, 12:57 GMT
Is there an actual bug right now?

I'm not able to publicly discuss the reasons why bitlbee stopped working with gtalk last time around.
Comment by dx (dx) - Thursday, 18 April 2013, 13:03 GMT
Yes, right now #bitlbee (OFTC) is getting a lot of users complaining about bitlbee going unresponsive, all of them use arch linux with gtalk accounts. And everyone who recompiled with gnutls fixed it.

(EDIT: nevermind what i said here before - I wasn't aware that falconindy works for google, so it makes sense now)
Comment by silenti (silenti620) - Thursday, 18 April 2013, 13:05 GMT
Right now bitlbee stops responding for periods longer than 1 minute at a time.
Several others on #bitlbee are experiencing the same as I'm writing this.

Loading...