Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33417 - [skype] qtwebkit 2.3git20130115-1 breaks it

Attached to Project: Community Packages
Opened by George Angelopoulos (l4than-d3vers) - Wednesday, 16 January 2013, 13:04 GMT
Last edited by Andrea Scarpino (BaSh) - Wednesday, 17 April 2013, 15:09 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Andrea Scarpino (BaSh)
Gavin Bisesi (Daenyth)
Florian Pritz (bluewind)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
After upgrading to qtwebkit 2.3git20130115-1 skype fails to start. Running skype on a terminal gives the following output:
segmentation fault (core dumped) skype

Steps to reproduce:
Run skype.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Wednesday, 17 April 2013, 15:09 GMT
Reason for closing:  Fixed
Additional comments about closing:  this was related to qtwebkit and has been fixed in past. please follow  FS#34630 
Comment by George Angelopoulos (l4than-d3vers) - Wednesday, 16 January 2013, 13:13 GMT
When trying to run skype this shows in /var/log/messages.log

Jan 16 15:13:23 localhost kernel: [ 6022.610908] traps: skype[1826] general protection ip:80796e8 sp:bfd2759c error:0 in skype[8048000+1b5c000]
Comment by Andrea Scarpino (BaSh) - Wednesday, 16 January 2013, 13:14 GMT
We cannot rebuild skype and we cannot downgrade qtwebkit as 2.2 doesn't build.
Comment by George Angelopoulos (l4than-d3vers) - Wednesday, 16 January 2013, 13:18 GMT
Forgot to mention: It only happens on i686 systems. Not x86_64. Sorry! (first bug report)
Comment by Andrea Scarpino (BaSh) - Wednesday, 16 January 2013, 13:33 GMT
Yes because there's no lib32-qtwebkit package in [multilib], so the qtwebkit version for x86_64 is still 2.2.2 (provided by the lib32-qt package).
Comment by Andrea Scarpino (BaSh) - Wednesday, 16 January 2013, 14:38 GMT
try skype 4.1.0.20-3 and let we know
Comment by George Angelopoulos (l4than-d3vers) - Thursday, 17 January 2013, 07:22 GMT
It works. tyvm!
Comment by nghia (nghiavd) - Monday, 15 April 2013, 01:57 GMT
  • Field changed: Percent Complete (100% → 0%)
I am getting the same error "Segmentation fault (core dump)" with Skype 4.1.0.20-5 and qtwebkit-2.3.beta2-2 on my 32bit system. On my 64bit Arch desktop, Skype works just fine.
Comment by Heinrich Siebmanns (Harvey) - Monday, 15 April 2013, 15:28 GMT
Same with Skype 4.1.0.20-6 and qtwebkit 2.3.0-1 on arch 32bit - Segfault.
Comment by nghia (nghiavd) - Monday, 15 April 2013, 15:43 GMT
This error only happens when you use glibc-git. Installing glibc solves it.
Comment by Andrea Scarpino (BaSh) - Monday, 15 April 2013, 15:49 GMT
FYI: qtwebkit has nothing to do with this since skype, for i686, includes a libQtWebKit library in its package.
Comment by Heinrich Siebmanns (Harvey) - Monday, 15 April 2013, 15:58 GMT
skype-4.1.0.20-6 segfaults with glibc-2.17-5 from core here.
Comment by Heinrich Siebmanns (Harvey) - Tuesday, 16 April 2013, 12:29 GMT Comment by Florian Pritz (bluewind) - Tuesday, 16 April 2013, 12:38 GMT
/usr/bin/skype is a wrapper around $LIBDIR/skype/skype. So yes, normal.

Loading...