Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33410 - dhcpcd@.service aliased to eth0

Attached to Project: Arch Linux
Opened by Curtis Shimamoto (WonderWoofy) - Wednesday, 16 January 2013, 04:40 GMT
Last edited by Eric Belanger (Snowman) - Wednesday, 16 January 2013, 09:26 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
dhcpcd@.service contains alias for old naming scheme.

Additional info:
* dhcpcd 5.6.4-1
* systemd 197-4
* /usy/lib/systemd/system/dhcpcd@.service


Steps to reproduce:
Simply enable the dhcpcd@.service.

Notes:
The dhcpcd@.service file (of the dhcpcd package obviously) contains this:

[Install]
Alias=multi-user.target.wants/dhcpcd@eth0.service

While this is typically what we would have wanted in the past, this is no longer the case with the new naming scheme for network devices under systemd 197-4.

Judging by the presence of the dhcpcd_.service file that is included with dhcpcd in ABS (which is then copied as dhcpcd@.service by the PKGBUILD), I assume that this is an Arch Linux contribution, and not something that is coming from upstream.

Personally, I just copied the file to the appropriate /etc/systemd/system/ and replaced the Alias= line with "WantedBy=multi-user.target" and all seems well.

I know that there was a bug report for the same topic that had previously been closed, but it now seems as though this issue is more relevant.
This task depends upon

Closed by  Eric Belanger (Snowman)
Wednesday, 16 January 2013, 09:26 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#31093 

see upstream bug: https://bugs.freedesktop.org/show_bug.cg i?id=53954
Comment by Curtis Shimamoto (WonderWoofy) - Wednesday, 16 January 2013, 04:41 GMT
Sorry, I forgot to change the categories on the right to the appropriate values. My bad.

Loading...