Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33382 - [erlang] unixodbc optdep not included in binary package

Attached to Project: Community Packages
Opened by Simon Schubert (corecode) - Sunday, 13 January 2013, 17:26 GMT
Last edited by Alexander F. Rødseth (xyproto) - Wednesday, 13 February 2013, 17:46 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Alexander F. Rødseth (xyproto)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date 2013-02-14
Percent Complete 100%
Votes 0
Private No

Details

Description:

erlang-nox (and erlang) list unixodbc as optdeps. The binary packages do not come with unixodbc support built in.


Steps to reproduce:

% pacman -Q -l erlang-nox|grep odbc
/usr/lib/erlang/man/man3/odbc.3.gz

Expected: (if built manually, configure --with-odbc)

% pacman -Q -l erlang-nox|grep odbc
erlang-nox /usr/lib/erlang/lib/odbc-2.10.13/
erlang-nox /usr/lib/erlang/lib/odbc-2.10.13/c_src/
erlang-nox /usr/lib/erlang/lib/odbc-2.10.13/c_src/odbcserver.c
erlang-nox /usr/lib/erlang/lib/odbc-2.10.13/c_src/odbcserver.h
erlang-nox /usr/lib/erlang/lib/odbc-2.10.13/ebin/
erlang-nox /usr/lib/erlang/lib/odbc-2.10.13/ebin/odbc.app
erlang-nox /usr/lib/erlang/lib/odbc-2.10.13/ebin/odbc.appup
erlang-nox /usr/lib/erlang/lib/odbc-2.10.13/ebin/odbc.beam
erlang-nox /usr/lib/erlang/lib/odbc-2.10.13/ebin/odbc_app.beam
erlang-nox /usr/lib/erlang/lib/odbc-2.10.13/ebin/odbc_sup.beam
erlang-nox /usr/lib/erlang/lib/odbc-2.10.13/include/
erlang-nox /usr/lib/erlang/lib/odbc-2.10.13/include/odbc.hrl
erlang-nox /usr/lib/erlang/lib/odbc-2.10.13/priv/
erlang-nox /usr/lib/erlang/lib/odbc-2.10.13/priv/bin/
erlang-nox /usr/lib/erlang/lib/odbc-2.10.13/priv/bin/odbcserver
erlang-nox /usr/lib/erlang/lib/odbc-2.10.13/priv/obj/
erlang-nox /usr/lib/erlang/lib/odbc-2.10.13/src/
erlang-nox /usr/lib/erlang/lib/odbc-2.10.13/src/odbc.erl
erlang-nox /usr/lib/erlang/lib/odbc-2.10.13/src/odbc_app.erl
erlang-nox /usr/lib/erlang/lib/odbc-2.10.13/src/odbc_internal.hrl
erlang-nox /usr/lib/erlang/lib/odbc-2.10.13/src/odbc_sup.erl
erlang-nox /usr/lib/erlang/man/man3/odbc.3.gz
This task depends upon

Closed by  Alexander F. Rødseth (xyproto)
Wednesday, 13 February 2013, 17:46 GMT
Reason for closing:  Fixed
Comment by Alexander F. Rødseth (xyproto) - Wednesday, 06 February 2013, 14:52 GMT
This wasn't fixed after all, as pointed out by  FS#33734  (duplicate).

I'll add the required make dependency.
Comment by Alexander F. Rødseth (xyproto) - Thursday, 07 February 2013, 13:52 GMT
No, instead I think I'll create a split package for erlang/erlang-nox/erlang-odbc, while compiling with "--with-odbc" and making erlang-odbc an optional dependency.
Comment by Alexander F. Rødseth (xyproto) - Wednesday, 13 February 2013, 17:45 GMT
Ok, now erlang will be compiled with "--with-odbc", and "erlang-unixodbc" is an optional dependency. Please re-open this ticket if there should be any problems.

Loading...