Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33378 - [wicd] wicd-curses broken

Attached to Project: Arch Linux
Opened by Anthony Clark (anthonyclark) - Sunday, 13 January 2013, 06:48 GMT
Last edited by Isenmann Daniel (ise) - Tuesday, 22 January 2013, 18:48 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Isenmann Daniel (ise)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 27
Private No

Details

Description:
Installing python2-urwid-1.1.1-1 will not let `wicd-curses` start.
The following traceback occurs when running wicd-curses as non-root and as root:


Traceback (most recent call last):
File "/usr/share/wicd/curses/wicd-curses.py", line 1063, in <module>
main()
File "/usr/share/wicd/curses/wicd-curses.py", line 995, in main
ui.run_wrapper(run)
File "/usr/lib/python2.7/site-packages/urwid/raw_display.py", line 242, in run_wrapper
return fn()
File "/usr/share/wicd/curses/wicd-curses.py", line 88, in wrapper
return func(*args, **kargs)
File "/usr/share/wicd/curses/wicd-curses.py", line 1003, in run
app = appGUI()
File "/usr/share/wicd/curses/wicd-curses.py", line 548, in __init__
self.wiredCB = urwid.Filler(WiredComboBox(wiredL))
File "/usr/share/wicd/curses/wicd-curses.py", line 378, in __init__
self.__super.__init__(use_enter=False)
File "/usr/share/wicd/curses/curses_misc.py", line 352, in __init__
self.focus = focus
AttributeError: can't set attribute



Additional info:
wicd 1.7.2.4-5
python-dbus-common 1.1.1-2
python2-dbus 1.1.1-2
dbus 1.6.8-6

Note that wicd-cli and wicd-gtk still work so it doesn't appear the daemon is
malfunctioning.


Steps to reproduce:
Assure the `wicd` and `dbus` services are running.
Install python2-urwid-1.1.1-1 which is the newest version in extra as of 1/11/13.
Attempt to execute `wicd-curses`
This task depends upon

Closed by  Isenmann Daniel (ise)
Tuesday, 22 January 2013, 18:48 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in new package version 6.
Comment by Marcos (Feirlane) - Sunday, 13 January 2013, 17:34 GMT
It's happening on my 32bit system too, same problem.
Comment by nil0x42 (nil0x42) - Monday, 14 January 2013, 11:58 GMT
exactly same issue for me on wicd-curses since the urwid upgrade to "python2-urwid-1.1.1-1"
Comment by Zhehao Mao (zhehao) - Monday, 14 January 2013, 22:51 GMT
A bug report for this has been filed upstream on Launchpad. https://bugs.launchpad.net/wicd/+bug/1075399

According to the bug report, it's been fixed in the latest bazaar commit, but I don't think it's been rolled into an official release yet.
Comment by bob (hemite) - Tuesday, 15 January 2013, 01:07 GMT
I have the same issue.
Comment by Bryce Guinta (azrathud) - Wednesday, 16 January 2013, 03:08 GMT
After upgrading to python2-urwid-1.1.1-1 I encountered this same issue. Downgrading to python2-urwid-1.0.2-2 circumvents the bug.

For anyone looking for a fix, and if you have the last version cached, run 'sudo pacman -U /var/cache/pacman/pkg/python2-urwid-1.0.2-2-x86_64.pkg.tar.xz' assuming you have it compiled for a 64-bit system, else look in /var/cache/pacman/pkg/ for your cached version.
Comment by Pontus Andersson (epontan) - Wednesday, 16 January 2013, 22:59 GMT
Perhaps the package could be re-built with the upstream patch?
http://bazaar.launchpad.net/~wicd-devel/wicd/experimental/diff/835

The correction is targeted for the next release of wicd (1.7.3), but it will probably be a while before it is released.
Comment by notch johnson (notch) - Thursday, 17 January 2013, 18:54 GMT
I can confirm that rebuilding the package with *both* patches from launchpad fixes the problem. Attached is a diff for PKGBUILD.
Comment by Alessio Biancalana (dottorblaster) - Thursday, 17 January 2013, 22:37 GMT
Broken for me too, I think these patches should be applied downstream too for now.
Comment by Juan Diego (juantascon) - Friday, 18 January 2013, 19:53 GMT
notch's patch works perfectly, thanks
Comment by Isenmann Daniel (ise) - Tuesday, 22 January 2013, 09:30 GMT
Thanks all for the investigation of the problem. I have build the package with the two patches, I will push it to the repos as soon as I'm at home to sign the packages. Should be in about 8-9 hours.
Comment by Alessio Biancalana (dottorblaster) - Tuesday, 22 January 2013, 10:51 GMT
Thanks to you ise! :)

Loading...