Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33327 - ruby - inconsistent gems install behavior

Attached to Project: Arch Linux
Opened by G. Richard Bellamy (rbellamy) - Tuesday, 08 January 2013, 05:50 GMT
Last edited by Thomas Dziedzic (tomd123) - Wednesday, 16 January 2013, 04:45 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Thomas Dziedzic (tomd123)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When installing ruby, a gemrc (/etc/gemrc) is created that sets --install-user globally. The wiki says "When running gem as a user, the gems will be installed into ~/.gem..." and "When running gem as root, gems will be installed for everyone on the machine."

During ruby installation, there is no /root/.gemrc created, which is needed to set --no-user-install to satisfy the statement in the wiki.
This task depends upon

Closed by  Thomas Dziedzic (tomd123)
Wednesday, 16 January 2013, 04:45 GMT
Reason for closing:  Not a bug
Additional comments about closing:  not a ruby bug
Comment by Thomas Dziedzic (tomd123) - Wednesday, 16 January 2013, 04:45 GMT
Please check out https://projects.archlinux.org/svntogit/packages.git/tree/trunk/ruby.install?h=packages/ruby
The wiki is wrong and should be updated to reflect what it is in the package.

Loading...