Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.

FS#33309 - XferCommand

Attached to Project: Pacman
Opened by Josh Cox (thoth) - Sunday, 06 January 2013, 16:59 GMT
Last edited by Dave Reisner (falconindy) - Sunday, 06 January 2013, 18:15 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


neither XferCommand given in:

#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u

work with my current version of pacman:

Pacman v4.0.3 - libalpm v7.0.3

I have a forum post here as well:

I opened this bug when I realized the commented out XferCommands in the default pacman.conf were just as broken as the custom wget command I was trying.
Additional info:
* package version(s)
* config and/or log files etc.

Steps to reproduce:

1. uncomment either of these two lines in pacman.conf

#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u

pacman -Syy

you should get errors such as this:

--2013-01-06 10:52:46--
Resolving (
Connecting to (||:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2013-01-06 10:52:46 ERROR 404: Not Found.

this has been confirmed with multiple repos and arch linux installations
This task depends upon

Closed by  Dave Reisner (falconindy)
Sunday, 06 January 2013, 18:15 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Working as intended. I suggest you avoid using XferCommand.
Comment by Josh Cox (thoth) - Sunday, 06 January 2013, 17:01 GMT
sorry I forgot to adjust meta data for this bug, not sure I can change category
Comment by Dave Reisner (falconindy) - Sunday, 06 January 2013, 18:14 GMT
There's no bug here. Your SigLevel implies DatabaseOptional so ALPM attempts to download the .sig file. With the internal downloader, we know that the database signature is optional, so 404 errors are ignored (and therefore not surfaced to the user).

If you want to "fix" this, then set DatabaseNever in your pacman.conf. There's nothing that we can do to "fix" DB updates done via XferCommand, since we have no control over the external program.
Comment by Josh Cox (thoth) - Sunday, 06 January 2013, 18:19 GMT
in that case, is there another way to limit the download rate of pacman's internal downloader?
Comment by Dave Reisner (falconindy) - Sunday, 06 January 2013, 18:27 GMT
No, there isn't. The downloader is intentionally dead simple, and I intend to keep it that way. It should have reasonable defaults which no user should ever need to worry about. Why do you need to limit the download rate?
Comment by Josh Cox (thoth) - Sunday, 06 January 2013, 20:41 GMT
Merely to keep it from consuming all available bandwidth. QoS is certainly an option for down the road, but I just wanted to be polite to the other people in my house at the moment. Please go ahead and close this bug. You have shown that it is not a bug like I was thinking. If you like please join us in the forum post to discuss further.