Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#3326 - kernel26 and ACPI

Attached to Project: Arch Linux
Opened by Aaron Griffin (phrakture) - Wednesday, 12 October 2005, 15:58 GMT
Last edited by arjan timmerman (blaasvis) - Sunday, 16 October 2005, 12:16 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Judd Vinet (judd)
Architecture not specified
Severity High
Priority Normal
Reported Version 0.7 Wombat
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Even since the gcc4 update (which pulled in kernel 2.6.13), ACPI has been a tad wonky.
Certain nodes in /proc/acpi (and outputs from `acpi`) either disappear or remain static. For a few days now, my (plugged in) laptop has been at "Battery: 35%, discharging" and my thermal zone is missing.

It seems I can get sporadic error messages, but nothing worth reporting. Others have also reported the issue on IRC.

In addition, the newest ndiswrapper (1.4) hangs for me when it attempts to set up wireless power management modes. I have a feeling this is related to the acpi issue, so I am hoping to get this fixed before messing with ndiswrapper again.

As a note, the current PKGBUILD uses lenb's acpi-20050815 patch, yet he has released acpi-20050902. I have no idea if this will fix it or not (I doubt it, but it's worth a shot).
This task depends upon

Closed by  arjan timmerman (blaasvis)
Monday, 23 January 2006, 10:13 GMT
Reason for closing:  Works for me
Additional comments about closing:  it is probably resolved in .15 by now, so i am closing it now.
Comment by Tobias Powalowski (tpowa) - Thursday, 13 October 2005, 05:38 GMT
hi the other patch doesn't work with the kernel source that's the reason for not upgrading this patch.
Comment by Aaron Griffin (phrakture) - Thursday, 13 October 2005, 15:00 GMT
I suspected as much. I still haven't found any info about this, and it seems that the issue is hit-or-miss - only about 20% of those I talk to have this issue.

The archck patchset uses some custom dsdt setup, which I should really try and see if it helps. If anyone is aware of other patches and/or settings which may help diagnose, please let me know.
Comment by Tobias Powalowski (tpowa) - Saturday, 22 October 2005, 15:52 GMT
is this fixed with new kernel -2?

Loading...