Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#33240 - [ubuntuone-client] 4.0.0-3 refuses to connect

Attached to Project: Community Packages
Opened by David López (David López) - Sunday, 30 December 2012, 02:21 GMT
Last edited by György Balló (City-busz) - Wednesday, 23 January 2013, 12:48 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To György Balló (City-busz)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No


I use 64bits arch with ubuntuone up to date (ubuntu-sso-client 4.0.0-2, ubuntuone-client 4.0.0-3, ubuntuone-control-panel 4.0.0-1 installed from arch's repo). ubuntuone suddenly refuses to sync. First it was stuck doing the local rescan, u1sdtool -s returned

connection: With User With Network
description: doing local rescan
is_connected: False
is_error: False
is_online: False
queues: WORKING

I reinstalled packages, refreshed shares and volumes... Not sure why but now it passes the local rescan, however it always stucks at server rescan. Now u1sdtool -s shows

connection: With User With Network
description: doing server rescan
is_connected: True
is_error: False
is_online: False
queues: WORKING

and ubuntuone-control-panel shows an IPCError (no further explanation).

The packages I've updated since my last sucessful ubuntuone sync were

[2012-12-28 10:52] upgraded cups-filters (1.0.25-1 -> 1.0.26-1)
[2012-12-28 10:52] upgraded git ( ->
[2012-12-28 10:52] upgraded grml-zsh-config (0.7.1-3 -> 0.7.3-1)
[2012-12-28 10:52] upgraded nspr (4.9.3-1 -> 4.9.4-1)
[2012-12-28 10:52] upgraded nss (3.14-1 -> 3.14.1-1)
[2012-12-28 10:52] upgraded tcl (8.6.0-2 -> 8.6.0-3)
[2012-12-28 10:52] upgraded transmission-cli (2.73-2 -> 2.75-1)
[2012-12-28 10:52] upgraded transmission-gtk (2.73-2 -> 2.75-1)
[2012-12-28 23:40] upgraded linux-api-headers (3.6.3-1 -> 3.7.1-1)
[2012-12-28 23:40] upgraded glibc (2.16.0-5 -> 2.17-1)
[2012-12-28 23:40] upgraded binutils (2.23.1-1 -> 2.23.1-2)
[2012-12-28 23:40] upgraded cloog (0.17.0-2 -> 0.18.0-1)
[2012-12-28 23:40] upgraded gcc-libs (4.7.2-2 -> 4.7.2-3)
[2012-12-28 23:40] upgraded gcc (4.7.2-2 -> 4.7.2-3)
[2012-12-28 23:40] upgraded gcc-fortran (4.7.2-2 -> 4.7.2-3)
[2012-12-28 23:40] upgraded lib32-glibc (2.16.0-5 -> 2.17-1)
[2012-12-28 23:40] upgraded lib32-gcc-libs (4.7.2-2 -> 4.7.2-3)
[2012-12-28 23:40] upgraded valgrind (3.8.1-1 -> 3.8.1-2)

Not sure if it's important, I use ubuntuone as root (with
im_ok_with_being_root_pretty_please_let_me_be_root.default = True in syncdaemon.conf). I've been using ubuntuone since August without problem, this is the first issue I can remember.

PD: a different user had experimented similar issues:
This task depends upon

Closed by  György Balló (City-busz)
Wednesday, 23 January 2013, 12:48 GMT
Reason for closing:  Fixed
Additional comments about closing:  in ubuntuone-client 4.0.0-4
Comment by yoklar (yoklar) - Sunday, 30 December 2012, 16:55 GMT
I use 32bits arch with ubuntuone up to date.. No sync for two days..

u1sdtool -c
ERROR:root:Could not find any typelib for Unity

u1sdtool -s
ERROR:root:Could not find any typelib for Unity
connection: With User With Network
description: processing the commands pool
is_connected: True
is_error: False
is_online: True
queues: IDLE

ubuntuone-control-panel-qt ==> IPCError
Comment by György Balló (City-busz) - Sunday, 30 December 2012, 17:18 GMT
Please attach the following log files:

Note that these files may contain sensitive information about your system (disk volume IDs; path of the shared folders).
Comment by yoklar (yoklar) - Sunday, 30 December 2012, 17:34 GMT
Comment by David López (David López) - Sunday, 30 December 2012, 17:44 GMT
Thanks György. I attach mine password protected, I send you the password to your e-mail.
Comment by György Balló (City-busz) - Monday, 31 December 2012, 06:13 GMT
It seems that the same happens on Fedora as someone reported to upstream:

I suggest to follow the upstream bug report, and try the following things:

1. Try to downgrade the 'nspr' package from 4.9.4-1 to 4.9.3-1.

If it doesn't help, then:

2. Try to reset Ubuntu One as described here:
Comment by Henning (Aldus) - Tuesday, 01 January 2013, 15:59 GMT
I have the same problem. Since december 30th syncing does not work any more. Resetting and reinstalling Ubuntu One did not help.
Comment by David López (David López) - Wednesday, 02 January 2013, 09:38 GMT
Thank you for your help, György. This issue is driving me crazy, downgrading nspr and reinstalling Ubuntu One didn't help.

The only solution I've found is downgrading ALL the packages I've updated and reinstalling Ubuntu One, tested 2 times and it seems to work. Then I slowly updated packges: I didn't notice anything strange when update cups-filters, git, grml-zsh-config, tcl, transmission-cli, transmission-gtk, but when I update gcc (and several related packages: linux-api-headers, gcc-libs, glibc, gcc-fortran, valgrind) problems appear. Am I wrong or is it possible that nspr in not the only 'conflictive' package?

I suggest people with this issue to check which packages have recently updated and downgrade them. Please share the list of updated packages to compare with mine. I found the packages in /etc/log/pacman.log, and older versions in /var/cache/pacman/pkg. Wish this helps.
Comment by Henning (Aldus) - Wednesday, 02 January 2013, 12:12 GMT
Thanks, David, for your investigation. See attached my pacman.log for december 2012. I noticed the problem on december 30th, it might have occurred on 29th.
Comment by David López (David López) - Wednesday, 02 January 2013, 12:50 GMT
Those are our common updated packages:

[2012-12-28 09:03] upgraded cups-filters (1.0.25-1 -> 1.0.26-1)
[2012-12-28 09:03] upgraded nspr (4.9.3-1 -> 4.9.4-1)
[2012-12-28 09:03] upgraded tcl (8.6.0-1 -> 8.6.0-3)
[2012-12-28 19:23] upgraded linux-api-headers (3.6.3-1 -> 3.7.1-1)
[2012-12-28 19:23] upgraded glibc (2.16.0-5 -> 2.17-1)
[2012-12-28 19:23] upgraded binutils (2.23.1-1 -> 2.23.1-2)
[2012-12-28 19:23] upgraded cloog (0.17.0-2 -> 0.18.0-1)
[2012-12-28 19:23] upgraded gcc-libs (4.7.2-2 -> 4.7.2-3)
[2012-12-28 19:23] upgraded gcc (4.7.2-2 -> 4.7.2-3)
[2012-12-28 19:23] upgraded nss (3.14-1 -> 3.14.1-1)

Not a great advance, but I suppose it's safe to update everything but those 10 packages. I will test it.
Comment by Nico (fireandfuel) - Thursday, 03 January 2013, 13:05 GMT
Hi, here is my pacman.log for the last update. Before this update u1 client worked fine.
Comment by Henning (Aldus) - Thursday, 03 January 2013, 19:21 GMT
Now I downgraded the following seven packages to the previous versions (see above):


and then completely removed all Ubuntu One configurations and reinstalled ubuntuone-client and ubuntuone-control-panel. Now syncing works as usual.

But as you can imagine, I am not really happy with this kind of solution.

May we expect an upgrade of the Ubuntu One client in which the problem will be fixed? György, did you contact the Ubuntu One developers at Canonical?
Comment by György Balló (City-busz) - Friday, 04 January 2013, 04:40 GMT
@Henning: no, I didn't contacted with upstream developers. Feel free to do this.
Comment by Henning (Aldus) - Friday, 04 January 2013, 08:11 GMT
I informed the Ubuntu One team and asked them to read this bug report page. I hope this issue to be resolved soon, as downgrading system components can only be a provisional solution.
Comment by David López (David López) - Thursday, 10 January 2013, 12:58 GMT
Updating firefox forces to update nspr and nss. I'm testing now with nss and nspr 4.9.4-1 and ubuntuone seems to work fine, I think the issue is generated by another packages. Acording to Henning's comments candidates are:


PD: upstream bug in lanchpad is marked low priority and triaged :(
Comment by David López (David López) - Wednesday, 16 January 2013, 03:05 GMT
I have just updated systemd 197-4, it printed some messages about glibc 2.17 not found and then I can't restart my computer (kernel panic). I had to downgrade systemd starting with an USB image and arch-croot. Beware!
Comment by Henning (Aldus) - Wednesday, 16 January 2013, 19:45 GMT
I had the same trouble yesterday. That's exactly what I was afraid of: that downgrading important system components will cause subsequent dependency problems. If it goes on like this, I fear that I will have to dismiss Ubuntu One. And I'm a bit amazed that apparently only very few people use Ubuntu One on Arch Linux.
Comment by Quentin Geissmann (qgeissmann) - Saturday, 19 January 2013, 13:30 GMT
I am experiencing the same bug since early january. Removing cache did not help.
Comment by David López (David López) - Saturday, 19 January 2013, 15:35 GMT
György posted in the upstream bug that the archlinux users were affected, but at this moment is triaged, on low priority and only affecting 4 users. I suggest all the affected users mark the tip 'this bug affects me' in, then the options that the bug is solved will increase. Also if anyone have some relevant information about the bug can post it in launchpad.
Comment by Henning (Aldus) - Saturday, 19 January 2013, 19:14 GMT
According to Distrowatch (, Ubuntu 12.10 uses glibc 2.15. One day in future, when the Ubuntu developers will upgrade to glibc 2.17, they will obviously be forced to fix the problem. But this can take a long time. Perhaps we can convince them to take care of this issue.
Comment by David López (David López) - Sunday, 20 January 2013, 02:44 GMT
Ubuntu snapshot uses 2.16: , so it is possible that this bug is not fixed in ubuntu 13.04. Honestly I can't wait so long, I've just update arch (and glibc) even if it brokes Ubuntu One. I'll probably migrate to Dropbox or Google Drive.
Comment by David López (David López) - Wednesday, 23 January 2013, 11:17 GMT
I can not test it now, but in the upstream bug there is a patch to solve it: Could someone test it?
Comment by György Balló (City-busz) - Wednesday, 23 January 2013, 12:48 GMT
I applied the patch, and it works for me, so I'm closing this bug. If you still experiencing problems with ubuntuone-client 4.0.0-4, feel free to reopen this bug, but make sure that the syncdaemon has been restarted first (with the u1sdtool -q command).