Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33228 - [wireless-regdb] no systemd service file

Attached to Project: Arch Linux
Opened by Lone_Wolf (Lone_Wolf) - Friday, 28 December 2012, 18:04 GMT
Last edited by Thomas Bächler (brain0) - Sunday, 06 January 2013, 21:41 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Thomas Bächler (brain0)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

There is no systemd service-file for etc/conf.d/wireless-regdom .

This forces me to stick with systemd initscripts emulation.

package version 2011.04.28-1

This task depends upon

Closed by  Thomas Bächler (brain0)
Sunday, 06 January 2013, 21:41 GMT
Reason for closing:  Not a bug
Comment by Greg (dolby) - Saturday, 29 December 2012, 21:16 GMT
IIRC a config file for this is uneeded for wireless-regdb to work and package could do without it.
Comment by Dave Reisner (falconindy) - Monday, 31 December 2012, 01:31 GMT
This continues to work exactly the same between sysvinit and systemd. There's no /etc/rc.d control script, so why do you think you need a unit for systemd?
Comment by Greg (dolby) - Monday, 31 December 2012, 19:30 GMT
@falconindy: isn't the kernel capable of finding out the correct regulatory domain without explicitly defining it in the conf.d file?
Comment by Dave Reisner (falconindy) - Monday, 31 December 2012, 19:36 GMT
I've no idea. crda is not something I need to deal with.
Comment by Lone_Wolf (Lone_Wolf) - Thursday, 03 January 2013, 00:06 GMT
I'm 99% certain in older versions of crda/wireless-regdom it was stated that you needed to put wireless-regdb in the daemons line , else it wouldn't work.
The install file of crda now says :
## arg 1: the new package version
post_install() {
echo "Uncomment the right regulatory domain in /etc/conf.d/wireless-regdom."
echo "It will automatically be set on boot."
}

It seems possible that the behaviour of crda/ wireless-regdom was changed, hopefully brain0 can confirm/deny this.
Comment by Thomas Bächler (brain0) - Sunday, 06 January 2013, 21:41 GMT
The regdom can be set by the kernel, if the AP broadcasts one. It can be set by the connection manager (wpa_supplicant, or a high-level manager like NetworkManager). If it is not configured there, we can still set it manually at boot, which is what the conf.d file does - most of the time, we don't need to.

Anyway, this is not a bug.

Loading...