Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33194 - virtualbox-modules wrong kernel

Attached to Project: Community Packages
Opened by Doug Newgard (Scimmia) - Monday, 24 December 2012, 19:53 GMT
Last edited by Sébastien Luttringer (seblu) - Tuesday, 25 December 2012, 15:29 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sébastien Luttringer (seblu)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

Description:

virtualbox-modules 4.2.6-1 is in [Community], but is requires the kernel from [Testing]
This task depends upon

Closed by  Sébastien Luttringer (seblu)
Tuesday, 25 December 2012, 15:29 GMT
Reason for closing:  Fixed
Additional comments about closing:  4.2.6-3 4.2.6-4
Comment by Dave Reisner (falconindy) - Monday, 24 December 2012, 20:00 GMT
No? It doesn't? For starters, there's no package called "virtualbox-modules".

Assume that's just a typo...

$ pkgfile -l community/virtualbox-host-modules
community/virtualbox-host-modules /usr/
community/virtualbox-host-modules /usr/lib/
community/virtualbox-host-modules /usr/lib/modules/
community/virtualbox-host-modules /usr/lib/modules/extramodules-3.6-ARCH/
community/virtualbox-host-modules /usr/lib/modules/extramodules-3.6-ARCH/vboxdrv.ko.gz
community/virtualbox-host-modules /usr/lib/modules/extramodules-3.6-ARCH/vboxnetadp.ko.gz
community/virtualbox-host-modules /usr/lib/modules/extramodules-3.6-ARCH/vboxnetflt.ko.gz
community/virtualbox-host-modules /usr/lib/modules/extramodules-3.6-ARCH/vboxpci.ko.gz

$ pkgfile -l community/virtualbox-guest-modules
community/virtualbox-guest-modules /usr/
community/virtualbox-guest-modules /usr/lib/
community/virtualbox-guest-modules /usr/lib/modules/
community/virtualbox-guest-modules /usr/lib/modules/extramodules-3.6-ARCH/
community/virtualbox-guest-modules /usr/lib/modules/extramodules-3.6-ARCH/vboxguest.ko.gz
community/virtualbox-guest-modules /usr/lib/modules/extramodules-3.6-ARCH/vboxsf.ko.gz
community/virtualbox-guest-modules /usr/lib/modules/extramodules-3.6-ARCH/vboxvideo.ko.gz

Looks like the kernel from [core] to me...

4.2.6-2 is in community-testing, and requires the kernel from [testing]. Notice the recurring "testing" theme.

edit: ah good. the depends are fubar.
Comment by Ionut Biru (wonder) - Monday, 24 December 2012, 20:01 GMT
the dependency is wrong.
Comment by Doug Newgard (Scimmia) - Monday, 24 December 2012, 20:09 GMT
Fine, falconindy, I said "requires" instead of "depends" and "package" instead of "PKGBUILD" (virtualbox-modules being a split package and appearing as that name on the front page).
Comment by patrick (potomac) - Tuesday, 25 December 2012, 00:50 GMT
the correct name for these 2 packages are :

virtualbox-guest-modules and virtualbox-guest-utils

Comment by Allan McRae (Allan) - Tuesday, 25 December 2012, 12:18 GMT
Just to be clear:

> pacman -Si community/virtualbox-guest-modules
Repository : community
Name : virtualbox-guest-modules
Version : 4.2.6-1
...
Depends On : linux>=3.7 linux<3.8

Loading...