Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33189 - [dhcpcd] systemctl enable dhcpcd@$LANINTERFACE only for eth0?

Attached to Project: Arch Linux
Opened by Manuel Reimer (M-Reimer) - Monday, 24 December 2012, 10:46 GMT
Last edited by Dave Reisner (falconindy) - Monday, 24 December 2012, 14:20 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hello archlinux team,

I tried to install a system where more than one ethernet card is installed. To make them appear at fixed names, I created udev rules as described on the Wiki. So my two network cards are now named "net0" and "net1".

The first card is just connected to an internet router, so I want to configure this one via dhcp. My command:

systemctl enable dhcpcd@net0

And the result: The symlink, created by "systemctl enable", points to "eth0" and not "net0". So after reboot, I didn't have a configured ethernet card. I had to rename the symlink manually to get what I expected to get. With the renamed symlink, anything works as it should...

Can someone please have a look at this?
This task depends upon

Closed by  Dave Reisner (falconindy)
Monday, 24 December 2012, 14:20 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#31093 

see upstream bug: https://bugs.freedesktop.org/show_bug.cg i?id=53954

Loading...