Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33186 - usb mass storage no longer mountable after removing usb in mkinitcpio.conf

Attached to Project: Arch Linux
Opened by Caleb Cushing (xenoterracide) - Sunday, 23 December 2012, 23:15 GMT
Last edited by Dave Reisner (falconindy) - Tuesday, 01 January 2013, 01:06 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I removed 'usb' from my HOOKS in mkinitcpio.conf. I do not use usb mass storage for anything required for boot. And in fact boot and everything but mounting usb mass storage worked fine. I have tested the failure with multiple usb ports (front and back), 2 different external hardrive enclosures and multiple hard drives. the machine would detect a device being plugged in, but not the storage that was connected. As soon as I re-enabled usb in the conf and booted up my device was again detected. I think this means there's a problem with udev? as it must not have been loading the appropriate kernel module on hotplug. But I'm not sure how all of these thigns are working together anymore. Will provide more information as requested.
This task depends upon

Closed by  Dave Reisner (falconindy)
Tuesday, 01 January 2013, 01:06 GMT
Reason for closing:  Not a bug
Comment by Dave Reisner (falconindy) - Monday, 24 December 2012, 00:37 GMT
The usb hook no longer exists. There's a lot of noise here and no detail about your config.
Comment by Caleb Cushing (xenoterracide) - Monday, 24 December 2012, 01:06 GMT
That's what I thought, which is why I removed it... however initrd shouldn't prevent this from being loaded by udev (or whatever would dynamically probe these days), present or not

cat /etc/mkinitcpio.conf | grep -v # slave-iv
MODULES="intel_agp i915"

BINARIES=""

FILES=""

HOOKS="base udev autodetect block mdadm usb filesystems usbinput fsck"

COMPRESSION="xz"
Comment by Caleb Cushing (xenoterracide) - Monday, 24 December 2012, 01:06 GMT
core/mkinitcpio 0.12.0-2 [installed]
Comment by Caleb Cushing (xenoterracide) - Monday, 24 December 2012, 01:09 GMT
Also you don't have to be rude about not including config info. I could have spammed about a million bits of data most of them would have been irrelevant.
Comment by Dave Reisner (falconindy) - Monday, 24 December 2012, 01:15 GMT
pacman -Q linux
uname -r
Comment by Dave Reisner (falconindy) - Thursday, 27 December 2012, 14:09 GMT
Ping?
Comment by Caleb Cushing (xenoterracide) - Saturday, 29 December 2012, 20:39 GMT
linux 3.6.10-1
3.6.10-1-ARCH
Comment by Dave Reisner (falconindy) - Saturday, 29 December 2012, 20:49 GMT
And you can still reproduce the issue? The usb hook doesn't exist anymore -- it just runs the block hook. Running the block hook twice is idempotent, so I see no reason that it should matter if usb is in your hooks or not.
Comment by Dave Reisner (falconindy) - Saturday, 29 December 2012, 20:58 GMT
btw, you can prove this to yourself by generating an image with and without the USB hook and comparing the contents via lsinitcpio.
Comment by Caleb Cushing (xenoterracide) - Tuesday, 01 January 2013, 00:45 GMT
ok, unable to reproduce.

Loading...