Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33095 - [linux] 3.7.0-1 Kernel panic

Attached to Project: Arch Linux
Opened by Sujith (sacamano_m82) - Friday, 14 December 2012, 15:07 GMT
Last edited by Tobias Powalowski (tpowa) - Thursday, 20 December 2012, 20:51 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Plugging in AC power supply freezes the system, it is being discussed upstream here:
https://lkml.org/lkml/2012/12/14/65

This is readily reproducible on my system.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Thursday, 20 December 2012, 20:51 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.7.1-2
Comment by William Giokas (KaiSforza) - Saturday, 15 December 2012, 16:50 GMT
I can confirm this behavior on my T420.

https://bugzilla.kernel.org/show_bug.cgi?id=51661

I submitted that bug two days ago along with an email to the arch-general list.
Comment by july (july) - Tuesday, 18 December 2012, 14:35 GMT
i was hitted by the bug, I did not use laptop-mode-tools (however, tried to install and disable them:)

the bug persists here, even when applying the proposed patch in https://lkml.org/lkml/2012/12/14/65

however on my system /proc/sys/kernel/nmi_watchdog dosen't exists.
Comment by Sujith (sacamano_m82) - Thursday, 20 December 2012, 02:39 GMT
A fix has been merged upstream: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=commit;h=3935e89505a1c3ab3f3b0c7ef0eae54124f48905
Adding this patch and rebuilding the package fixes the issue for me.
Comment by july (july) - Thursday, 20 December 2012, 07:35 GMT
the commit is the same one as the proposed patch in https://lkml.org/lkml/2012/12/14/65

so no fix for me :)

i am not able to post new comment, so edit this one

i doubt that the bug had something with cpuidle ...
so tried:
intel_idle.max_cstate=0 processor.max_cstate=0 idle=poll
and now i am able to unplug and plug the ac power :)
Comment by William Giokas (KaiSforza) - Thursday, 20 December 2012, 16:30 GMT
july: Could you bisect your kernel for us, please? I'm curious as to which commit was the offending one for you, and the more information we have, the more likely that this bug can be fixed.
Comment by Tobias Powalowski (tpowa) - Thursday, 20 December 2012, 20:51 GMT
Patch applied to 3.7.1-2 package, please open a new bug for your issue july.

Loading...