Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#33042 - [cantata] unstable with KDE 4.9.4

Attached to Project: Community Packages
Opened by Martin Corley (martinc) - Tuesday, 11 December 2012, 14:19 GMT
Last edited by Andrea Scarpino (BaSh) - Friday, 14 December 2012, 11:42 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



cantata 0.9.0-1 works with KDE 4.9.3 but is unstable with KDE 4.9.4. On connection to mpd it either

* crashes silently
* crashes partially, leaving an icon in the systray (and working systray controls) but no possibility to open a window
* works (on rare occasions)

aur/cantata-qt works as expected

Additional info:
* kdebase-runtime 4.9.4-1
* valgrind output (courtesy of mnx):
* forums thread:

Steps to reproduce:
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Friday, 14 December 2012, 11:42 GMT
Reason for closing:  Fixed
Additional comments about closing:  cantata 0.9.1-1 (re-open if it's not)
Comment by Andrea Scarpino (BaSh) - Tuesday, 11 December 2012, 15:26 GMT
This should be reported upstream.
Comment by Martin Corley (martinc) - Tuesday, 11 December 2012, 15:33 GMT