Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32997 - [xf86-video-nouveau] Optimus (enabled in UEFI) Lenovo T520 causes Xorg to crash at start.

Attached to Project: Arch Linux
Opened by Edward O'Callaghan (evocallaghan) - Friday, 07 December 2012, 03:27 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 18 December 2012, 15:41 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andreas Radke (AndyRTR)
Ionut Biru (wonder)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Currently if Optimus is enabled in UEFI firmware the Lenovo T520 series crashes Xorg at start in the following way;

[ 5.535] removing GPU device /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/drm/card1 31844352
[ 5.535] xf86: remove device 0 /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/drm/card1
[ 5.535] (II) NOUVEAU(G0): NVLeaveVT is called.
[ 5.535] (II) NOUVEAU(G0): Closed GPU channel 1
[ 5.535] (II) UnloadModule: "nouveau"
[ 5.535] (II) UnloadSubModule: "shadowfb"
[ 5.535] (II) Unloading shadowfb
[ 5.535] (II) UnloadSubModule: "exa"
[ 5.535] (II) Unloading exa
[ 5.535] (II) UnloadSubModule: "fb"
[ 5.535] (II) Unloading fb
[ 5.536] (II) config/udev: Adding drm device (/dev/dri/card1)
[ 5.536] (II) config/udev: Adding drm device (/dev/dri/card1)
[ 5.536] (II) LoadModule: "modesetting"
[ 5.536] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[ 5.536] (II) Module modesetting: vendor="X.Org Foundation"
[ 5.536] compiled for 1.13.0, module version = 0.5.0
[ 5.536] Module class: X.Org Video Driver
[ 5.536] ABI class: X.Org Video Driver, version 13.0
[ 5.536] (II) modesetting(G0): using drv /dev/dri/card1
[ 5.536] hotplugged device 0 didn't configure
[ 5.536] (II) UnloadModule: "modesetting"
[ 5.536] xf86: found device 1
[ 5.536] (EE)
[ 5.536] (EE) Backtrace:
[ 5.536] (EE) 0: /usr/bin/X (xorg_backtrace+0x36) [0x58a326]
[ 5.536] (EE) 1: /usr/bin/X (0x400000+0x18e179) [0x58e179]
[ 5.536] (EE) 2: /usr/lib/libpthread.so.0 (0x7f585d401000+0xf1a0) [0x7f585d4101a0]
[ 5.536] (EE) 3: /usr/lib/xorg/modules/drivers/nouveau_drv.so (0x7f585a9a2000+0x24853) [0x7f585a9c6853]
[ 5.536] (EE) 4: /usr/bin/X (WakeupHandler+0x6b) [0x43c1db]
[ 5.536] (EE) 5: /usr/bin/X (WaitForSomething+0x1a4) [0x587764]
[ 5.536] (EE) 6: /usr/bin/X (0x400000+0x37bb1) [0x437bb1]
[ 5.536] (EE) 7: /usr/bin/X (0x400000+0x2696a) [0x42696a]
[ 5.536] (EE) 8: /usr/lib/libc.so.6 (__libc_start_main+0xf5) [0x7f585c08f725]
[ 5.536] (EE) 9: /usr/bin/X (0x400000+0x26cad) [0x426cad]
[ 5.536] (EE)
[ 5.536] (EE) Segmentation fault at address 0x676e69
[ 5.536]
Fatal server error:
[ 5.536] Caught signal 11 (Segmentation fault). Server aborting
[ 5.536]
[ 5.536] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 5.536] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 5.536] (EE)
[ 5.546] (II) evdev: Power Button: Close
[ 5.546] (II) UnloadModule: "evdev"
[ 5.547] (II) evdev: Video Bus: Close

I don't exactly find this too surprising since Optimus is not properly supported in Linux as such yet.
However the segmentation fault looks somewhat rough/harsh..
Thus, I am not sure if this is actually a pressing issue or if something is just not handled properly
about some addression region that can not be read?

Additional info:
* package version(s)

. Linux dexter 3.6.9-1-ARCH #1 SMP PREEMPT Tue Dec 4 08:04:10 CET 2012 x86_64 GNU/Linu
. xorg-server 1.13.0-4
. xf86-video-intel 2.20.15-1
. xf86-video-modesetting 0.5.0-1
. xf86-video-nouveau-1.0.4-1
. nouveau-dri-9.0.1-1

* config and/or log files etc.

Anything I forgot?
Kind Regards,
Edward.

Steps to reproduce:
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 18 December 2012, 15:41 GMT
Reason for closing:  Upstream
Comment by Edward O'Callaghan (evocallaghan) - Friday, 07 December 2012, 03:32 GMT
Opps, sorry.

It is a Lenovo T530.. I can't see where to edit in flyspry..
Comment by Gerardo Exequiel Pozzi (djgera) - Friday, 14 December 2012, 23:41 GMT
  • Field changed: Summary (Optimus (enabled in UEFI) Lenovo T520 causes Xorg to crash at start. → [xf86-video-nouveau] Optimus (enabled in UEFI) Lenovo T520 causes Xorg to crash at start.)
  • Field changed: Status (Unconfirmed → Assigned)
  • Field changed: Category (System → Upstream Bugs)
  • Task assigned to Andreas Radke (AndyRTR), Ionut Biru (wonder)
upstream report?

Loading...