Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32983 - [xcircuit] segfaults

Attached to Project: Community Packages
Opened by costantino (costantino) - Thursday, 06 December 2012, 07:56 GMT
Last edited by Eric Belanger (Snowman) - Tuesday, 10 September 2013, 03:15 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description and steps to reproduce:
I noticed that when I place a component on the circuit and then I undo the action the program crashes immediately with this error: Segmentation fault (core dumped).
It might be an architecture issue since a friend of mine with archi686 doesn't have this problem.

Additional info:
xcircuit 3.7.26-2
tk 8.5.13-1
tcl 8.5.13-1
libxpm 3.5.10-1
zlib 1.2.7-1
kernel 3.6.9-1-ARCH
Architecture x86-64
This task depends upon

Closed by  Eric Belanger (Snowman)
Tuesday, 10 September 2013, 03:15 GMT
Reason for closing:  Fixed
Additional comments about closing:  should work now with tk-8.6.0-3
Comment by Jelle van der Waa (jelly) - Sunday, 23 December 2012, 10:54 GMT
Confirmed, fails for me
Here is the devel version of xcircuit, maybe that one works http://pkgbuild.com/~jelle/PKGBUILD
Comment by Giuseppe Borzi (gborzi) - Friday, 04 January 2013, 01:40 GMT
This problem appears on i686 as well, just checked on my netbook. Downgrading tcl and tk to 8.5.13 (and recompiling xcircuit) fix the problem.
Comment by Johnny Oskarsson (joskar) - Wednesday, 03 April 2013, 07:38 GMT
Downgrading tcl and tk fixes the problem for me as well. Didn't need to recompile xcircuit though. (tcl and tk 8.5.12)
Comment by Giuseppe Borzi (gborzi) - Monday, 09 September 2013, 22:47 GMT
I've found a solution to this bug, which is actually a tk 8.6.0 bug. The patch from http://ftp.bitmover.com/tk/info/7ece6c712b applied to tk solves the problem. I'm going to report the tk bug.

Loading...