Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32969 - [systemd] systemd-analyze requires gi.repository.Gio python module

Attached to Project: Arch Linux
Opened by Radu Potop (wooptoo) - Wednesday, 05 December 2012, 08:35 GMT
Last edited by Evangelos Foutras (foutrelis) - Wednesday, 05 December 2012, 19:08 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

systemd-analyze requires gi.repository.Gio python module. I think this is a part of the pygtk3 package, since I already have pygtk 2.24.0 installed.

Reproduction:

$ systemd-analyze

Traceback (most recent call last):
File "/usr/bin/systemd-analyze", line 5, in <module>
from gi.repository import Gio
ImportError: No module named gi.repository


Additional info:

Name : systemd
Version : 196-2
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Wednesday, 05 December 2012, 19:08 GMT
Reason for closing:  Not a bug
Comment by Dave Reisner (falconindy) - Wednesday, 05 December 2012, 10:57 GMT
No, it requires python2-gobject, as noted by the optdepends.

Loading...