Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32948 - [accountsservice] Gnome online accounts keeps on expiring since 0.6.29-2

Attached to Project: Arch Linux
Opened by Frederic Bezies (fredbezies) - Monday, 03 December 2012, 17:42 GMT
Last edited by Ionut Biru (wonder) - Monday, 03 December 2012, 18:19 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: Since upgrade to accountsservice 0.6.29-2, my gnome account keeps on expiring. Deleting an creating again my google account doesn't change a thing.


Additional info:
accountsservice 0.6.29-2

Steps to reproduce:
Just get this version on your gnome. And create an account. It keeps on expiring after a few minutes.

Got this error in /var/log/everything.log

Dec 3 18:31:01 localhost goa[690]: /org/gnome/OnlineAccounts/Accounts/account_1354555860: Setting AttentionNeeded to TRUE because EnsureCredentials() failed with: Credentials not found in keyring (goa-error-quark, 0): Failed to retrieve credentials from the keyring (goa-error-quark, 4) [goadaemon.c:1248, ensure_credentials_cb()]

Downgrading to 0.6.29-1 doesn't fix the bug.
This task depends upon

Closed by  Ionut Biru (wonder)
Monday, 03 December 2012, 18:19 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#32668 
Comment by Frederic Bezies (fredbezies) - Monday, 03 December 2012, 17:44 GMT
Looks like it is kinda related to dbus update.

Here is the log before last expiration in google online accounts :

Dec 3 18:41:29 localhost dbus[333]: [system] Reloaded configuration
Dec 3 18:41:29 localhost dbus-daemon[333]: dbus[333]: [system] Reloaded configuration
Dec 3 18:41:29 localhost dbus[333]: [system] Reloaded configuration
Dec 3 18:42:02 localhost goa[690]: /org/gnome/OnlineAccounts/Accounts/account_1354556510: Setting AttentionNeeded to TRUE because EnsureCredentials() failed with: Credentials not found in keyring (goa-error-quark, 0): Failed to retrieve credentials from the keyring (goa-error-quark, 4) [goadaemon.c:1248, ensure_credentials_cb()]
Comment by Ionut Biru (wonder) - Monday, 03 December 2012, 17:49 GMT
how this is related to accountsservice?

this bug is a duplicate of  FS#32668 

Loading...