Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32927 - [gconf] causes banshee to crash

Attached to Project: Arch Linux
Opened by Luciano Ruete (luchano) - Saturday, 01 December 2012, 21:02 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 13 March 2013, 13:57 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 18
Private No

Details

Description:

gconf is causing banshee (and maybe other applications) to crash.
As reported in this issue[0] just applying this patch[1] solves the problem.


[0] https://bugs.archlinux.org/task/32390
[1] https://bazaar.launchpad.net/~timo-jyrinki/gconf/ubuntu.support-s-to-as-migrations/view/head:/debian/patches/call-dbus_g_thread_init.patch

Additional info:
* package version(s)
local/gconf 3.2.5-3
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 13 March 2013, 13:57 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in gconf-sharp.

Why fixing it there and not in gconf itself:
- the proposed patch is incorrect, will cause side effects for apps that call any dbus function before calling into gconf
- Mono applications will not call into dbus directly anyways because they use native dbus-sharp, so fixing it there is safe
Comment by Nate G. (nateg3.14159) - Sunday, 02 December 2012, 05:46 GMT
Confirming both the bug, and the patch
Comment by Jan de Groot (JGC) - Monday, 03 December 2012, 12:36 GMT
We won't include that patch, as upstream says it's not the way it should get fixed:
https://bugzilla.gnome.org/show_bug.cgi?id=683830
Comment by Luciano Ruete (luchano) - Monday, 03 December 2012, 12:52 GMT
Ok. Do you know from which package to expect the fix? It will be a gconf fix or a banshee fix?
Comment by Jan de Groot (JGC) - Monday, 03 December 2012, 13:39 GMT
I guess these crashes are not limited to banshee. So far most applications have migrated to gsettings which means they're no longer affected by this.

My guess is that this will get fixed in gconf some day, but I don't know if that's before or after Banshee has moved to gsettings.
Comment by pictuga (pictuga) - Monday, 03 December 2012, 15:13 GMT
I know the patch is not "clean", but I think it's a crazy idea to keep a broken package (banshee and maybe others), just cause it's not clean… and banshee is rather big in gnome. I don't think it's a "rather than unnecessary patching" (from the Arch Way, but maybe not "code-elegance") since this patch avoids serious crashes that happen near 100% of the time. Using the patch till is get solved upstream would be a nice move for banshee users.
Comment by Jan de Groot (JGC) - Monday, 03 December 2012, 16:12 GMT
The patch is broken. So far only ubuntu applies it, Debian and Redhat refuse to patch it.
Comment by Luciano Ruete (luchano) - Monday, 03 December 2012, 21:24 GMT
I understand Jan's arguments, but neither Debian nor Redhat are rolling release distributions. Arch's users are used to upgrade their systems very often, and that's why I think this bug is going to hit hard on several Arch users. More and more while the no-fix time window keeps growing.
The patch is a one-liner that can be easly reverted and seems to be stable enough as opossed to the un-patched version.
That said, I understand I'm not a maintainer and maybe this arguments are not strong enough to include the inappropriated (but working) fix.
Comment by Aaron Barany (akb825) - Saturday, 15 December 2012, 20:18 GMT
It's not really broken: the documentation for dbus_g_thread_init() says it can't be called more than once, but the implementation allows it. (https://bugs.freedesktop.org/show_bug.cgi?id=54770) It may not be the "ideal" fix, but right now banshee and any other multithreaded application that uses gconf and dbus are unusable, and have been for the past month and a half. Since there's no other fix in sight, how many more months will will these applications be broken with the default install? Especially with Banshee being one of the major music players, this is a pretty big deal...
Comment by Jonathan Csanyi (jcsanyi) - Wednesday, 02 January 2013, 21:11 GMT
This appears to be causing problems with Tomboy as well.
See https://bugzilla.gnome.org/show_bug.cgi?id=662358
Comment by bob (hemite) - Tuesday, 12 February 2013, 04:10 GMT
Confirming the bug as well for me. I also support including the patch into the arch version of the package until a patch from upstream is released.
Comment by Agustin Ferrario (py_crash) - Friday, 01 March 2013, 15:30 GMT
This bug also affects me... gconf keeps crashing my apps. I think the patch should applied because our are unstable right now, and the only solution I see is to patch the application myself, but it's not the ways thing should be done.

Loading...