Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32911 - [nss_ldap, pam_ldap] nss-pam-ldapd deprecates/replaces nss_ldap + pam_ldap, should be moved from AUR

Attached to Project: Community Packages
Opened by Zack Buhman (buhman) - Friday, 30 November 2012, 05:28 GMT
Last edited by Federico Cinelli (Cinelli) - Monday, 18 March 2013, 14:34 GMT
Task Type Feature Request
Category Packages
Status Closed
Assigned To Federico Cinelli (Cinelli)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

From the nss-pam-ldapd project page, http://arthurdejong.org/nss-pam-ldapd/ :

"""
The NSS module is originally a fork of nss_ldap with some structural design improvements. The most important features of nss-pam-ldapd are:

light and simple NSS and PAM libraries
avoid loading LDAP and SSL libraries in all programs
separation between NSS, PAM and LDAP code
fewer connections to the LDAP server
better debugging possibilities
better performance
"""

And when they say "better debugging possibilities", they really do mean it. This should be included in the official repositories so that it can be (more) easily deployed and maintained on several arch linux ldap-client boxen.

The current PKGBUILD from the AUR package https://aur.archlinux.org/packages/nss-pam-ldapd/ is quite clean, and already includes proper systemd units.
This task depends upon

Closed by  Federico Cinelli (Cinelli)
Monday, 18 March 2013, 14:34 GMT
Reason for closing:  Fixed
Additional comments about closing:  nss-pam-ldapd added to [community]
Comment by Federico Cinelli (Cinelli) - Saturday, 02 March 2013, 23:23 GMT
I cannot move it, waiting on my key to be signed. If another TU would like to move it to [community] I'll adopt and maintain it. I have already prepared the package.
Comment by Christoph Seitz (go2sh) - Sunday, 03 March 2013, 13:14 GMT
Would it be nice, if this package move someone to extra or even to core?
Providing proper authentification system is one of the major task a operation system should do.
Comment by Thiago Okada (m45t3r) - Monday, 04 March 2013, 16:33 GMT
This change would fix  FS#33672 , since that problem doesn't occur with nss-pam-ldapd (tested on my lab machines).

Loading...