Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32902 - [dbus-core] Apply upstream patch "Set correct address when using --address=systemd:"

Attached to Project: Arch Linux
Opened by Thomas Bächler (brain0) - Thursday, 29 November 2012, 17:13 GMT
Last edited by Tom Gundersen (tomegun) - Monday, 03 December 2012, 11:41 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

When dbus is run as session bus, the option --address=systemd: does not work correctly. I can't tell what exactly the problem is, all I know that using the dbus units from [1] is impossible.

There is a patch in the upstream dbus repository that fixes this problem ([2]). Unfortunately, the freedesktop.org git repositories fail to respond right now, so I am attaching the patch.

[1] https://github.com/sofar/user-session-units
[2] http://cgit.freedesktop.org/dbus/dbus/commit/?id=d728fdc655f17031da3bb129ab2fd17dadf0fe3a
This task depends upon

Closed by  Tom Gundersen (tomegun)
Monday, 03 December 2012, 11:41 GMT
Reason for closing:  Implemented
Additional comments about closing:  In testing.

Loading...