Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32878 - [akonadi] Introduce "Akonadi-backend" to choose between MySQL and PostgreSQL

Attached to Project: Arch Linux
Opened by H W Tovetjärn (totte) - Tuesday, 27 November 2012, 11:09 GMT
Last edited by Andrea Scarpino (BaSh) - Saturday, 02 February 2013, 17:57 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

As has been done for Phonon by the either/or-dependency "phonon-backend" would be nice to see introduced for Akonadi as well, i.e. "akonadi-backend", in which the user is prompted to install either MySQL or PostgreSQL. Possibly SQLite as well, since the wiki article on KDE/Akonadi suggests it also being supported.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Saturday, 02 February 2013, 17:57 GMT
Reason for closing:  Not a bug
Additional comments about closing:  You can already switch to sqlite/postgresql editing your config.
MySQL is the suggested backend so our akonadi package will use it (and then require it)
Comment by Andrea Scarpino (BaSh) - Tuesday, 04 December 2012, 21:03 GMT
"PostgreSQL Support
Has been merged for Akonadi server 1.3. We still need a volunteer for continuous testing and maintenance though."

It seems to me that it isn't a good choice.

About the SQlite one, I'd understand that we need to apply extra patches to qt and sqlite. I'd like to avoid this.
Comment by H W Tovetjärn (totte) - Thursday, 06 December 2012, 12:42 GMT
Akonadi is at 1.8 now and PostgreSQL support appears to be rather stable to me (not that I've read the changelogs or anything). Why the reluctance? I've skimmed through the documentation but haven't found anything specifically requiring MySQL features. Neither have I encountered any bugs in my personal usage - but perhaps my setup is too simple to push it.

I understand though that SQLite isn't up to the task due to it not being able to "handle the concurrent access very well" (http://techbase.kde.org/Projects/PIM/Akonadi#Why_not_use_sqlite.3F).
Comment by Andrea Scarpino (BaSh) - Saturday, 08 December 2012, 18:06 GMT
Talking with the akonadi devs on IRC they say that users can change their config to use postgresql (which is OK) or sqlite (which still has some issue).

They are both enabled in our akonadi package.

Loading...