Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32862 - [ibus-libpinyin] Gnome 3 is still broken

Attached to Project: Community Packages
Opened by Kerrick Staley (KerrickStaley) - Monday, 26 November 2012, 08:58 GMT
Last edited by Felix Yan (felixonmars) - Monday, 18 February 2013, 08:27 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

I have Gnome 3 installed along with the following packages:

ibus 1.4.99.20121109-1
ibus-libpinyin 1.4.93-1
ibus-qt 1.3.1-6

In Gnome's "Region and Language" settings pane, the ibus-libpinyin input source isn't listed; the only Chinese input source listed is "Chinese" (which does nothing; see https://bugzilla.gnome.org/show_bug.cgi?id=687596).

ibus-libpinyin *is* listed in ibus-setup's menus, and everything appears to work when ibus-libpinyin is configured via ibus-setup: the IBus menu appears in the panel and ibus-libpinyin is listed there. However, selecting ibus-libpinyin from the panel menu has no effect; the keyboard still behaves as an ordinary QWERTY keyboard.
This task depends upon

Closed by  Felix Yan (felixonmars)
Monday, 18 February 2013, 08:27 GMT
Reason for closing:  Not a bug
Additional comments about closing:  IBus integration enabled in g-s-d.
Comment by Ma Xiaojun (damage3025) - Wednesday, 02 January 2013, 23:00 GMT
This is a problem of GNOME I believe.
When IBus is used alone, the settings UI is always ibus-setup.

When GNOME disable IBus integration at compile-time or a certain gsettings key [1] is false, it should be GNOME's duty to inform the user "help yourself".
As I tried a few days ago, there is no clear indication, if some input sources added from g-c-c they just do nothing; this is same as your description.

1. https://live.gnome.org/ThreePointFive/Features/IBus#How_to_use_other_IM_frameworks
Comment by Kerrick Staley (KerrickStaley) - Monday, 18 February 2013, 08:05 GMT
This works now. I'm not sure when exactly it was fixed.

Loading...