Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#32859 - [firefox] v17.0 must be refocused to accept keyboard input

Attached to Project: Arch Linux
Opened by Kevin Knerr (barthel) - Monday, 26 November 2012, 03:25 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Monday, 26 November 2012, 16:32 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


When Firefox is first launched, it will not accept keyboard input, but mouse input works. If focus is given to another window and Firefox is refocused, keyboard input is accepted.

If I work in another window and return to Firefox, it appears to be focused but doesn't accept keyboard input.

This behavior does not appear when Firefox is reverted to v 16.0.2

Additional info:
* firefox-17.0-1-x86_64.pkg.tar.xz
* fluxbox-1.3.2-1-x86_64.pkg.tar.xz
* xorg-server-1.13.0-4-x86_64.pkg.tar.xz
* linux-3.6.7-1-x86_64.pkg.tar.xz

Althoug I am using "MouseFocus" in fluxbox, the fact that I can click on the Firefox window and still not be able to enter text suggest it is not a focus model problem.

I reverted to 16.0.2 and the problem disappeared, which suggests it is not related to plugins or other add-ons (except for the possibility that Firefox 17 handles them differently).

I've attempted Googling this issue and only came up with old reports against earlier versions.

I will follow up with a test of 17.0 with add-ons disabled. Are there any other tests I can run?

Steps to reproduce:
1) Launch firefox
2) Attempt to type a URL or enter search terms. There will be no cursor and Firefox will appear to be frozen
3) Focus another window, then return focus to firefox
4) Text entry is now possible
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Monday, 26 November 2012, 16:32 GMT
Reason for closing:  Not a bug
Comment by Kevin Knerr (barthel) - Monday, 26 November 2012, 03:29 GMT
Just reinstalled 17.0 and am unable to reproduce the bug. Possibly there was an install problem on the inital upgrade. Requesting closure.