Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32858 - [vlc] png files made with taking snapshots in vlc can't be opened.

Attached to Project: Arch Linux
Opened by Liu Yuyang (reverland) - Monday, 26 November 2012, 01:33 GMT
Last edited by Giovanni Scafora (giovanni) - Monday, 27 May 2013, 19:56 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Giovanni Scafora (giovanni)
Architecture All
Severity Low
Priority Normal
Reported Version 4.0.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Summary and Info:

the png files made with taking snapshots in vlc can't be opened.

I don't know whether 32bit system has the same problem.but it looks 64-bit indeed:

https://bbs.archlinux.org/viewtopic.php?pid=1198575#p1198575

the vlc information here:

VLC media player 2.0.4 Twoflower (revision 2.0.3-289-g6e6100a)
VLC version 2.0.4 Twoflower (2.0.3-289-g6e6100a)
Compiled by nobody on ioni (Nov 15 2012 20:05:02)

Steps to Reproduce:

Just taking snapshot in vlc and get an png image.

The png file gets written and but can't be opened(seems that it's always of the same size). Opening it with Gimp gives the error message:

Opening '/home/me/vlcsnap-2012-11-25-13h57m02s145.png' failed: Error while reading '/home/me/vlcsnap-2012-11-25-13h57m02s145.png'. File corrupted?

Using imagemagick's identify to get info about the file results in:

~$ identify vlcsnap-2012-11-25-13h57m02s145.png
identify: improper image header `vlcsnap-2012-11-25-13h57m02s145.png' @ error/png.c/ReadPNGImage/3743.


This task depends upon

Closed by  Giovanni Scafora (giovanni)
Monday, 27 May 2013, 19:56 GMT
Reason for closing:  Upstream
Comment by Greg (imrehg) - Monday, 10 December 2012, 01:51 GMT
The report https://bugs.archlinux.org/task/33021 is duplicate of this.
Comment by Ben Oliver (benoliver999) - Tuesday, 18 December 2012, 18:27 GMT
I can confirm I get this bug too with a fully up to date system. JPGs work OK though.
Comment by Dan McGee (toofishes) - Tuesday, 18 December 2012, 20:18 GMT
  • Field changed: Attached to Project (Pacman → Arch Linux)
  • Field changed: Summary (png files made with taking snapshots in vlc can't be opened. → [vlc] png files made with taking snapshots in vlc can't be opened.)
Check your project next time, please.
Comment by Liu Yuyang (reverland) - Wednesday, 19 December 2012, 11:39 GMT
In fact,I was aware of the wrong project immediately after posting this bug,but I don't know how to change it...Sorry for that.
Comment by Philip Sequeira (qmega) - Friday, 12 April 2013, 18:00 GMT
  • Field changed: Percent Complete (100% → 0%)
Broken again (2.0.5-4). PNG snapshot gives me a file full of zeros (JPG is fine).
Comment by Diego Viola (diegoviola) - Tuesday, 30 April 2013, 00:15 GMT
I have this problem as well, VLC 2.0.6 here.

Shouldn't this be reported upstream?
Comment by Giovanni Scafora (giovanni) - Tuesday, 30 April 2013, 20:22 GMT
Please report this to the upstream
Comment by Diego Viola (diegoviola) - Tuesday, 30 April 2013, 21:56 GMT

Loading...