Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32818 - [pulseaudio] freezes the whole KDE desktop

Attached to Project: Arch Linux
Opened by Andrej Podzimek (andrej) - Friday, 23 November 2012, 21:00 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Monday, 26 November 2012, 16:37 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

After an update roughly 2 days ago, pulseaudio stopped working. This happens quite often anyway, but this time there is a more serious problem: All applications that may have anything in common with sound simply freeze. Killing pulseaudio with -9 "unfreezes" them for a while -- until pulseaudio gets respawned.

Additional info:
* package version(s)

rtkit 0.11-1
pulseaudio 2.1-1

* config and/or log files etc.

I don't know how to get logs from pulseaudio (if it produces any).

This issue may be related to a failure of the rtkit daemon, which appears in the journal like this:

Nov 23 21:44:47 octopus systemd[1]: Starting RealtimeKit Scheduling Policy Service...
Nov 23 21:44:47 octopus systemd[24204]: Failed at step NETWORK spawning /usr/lib/rtkit/rtkit-daemon: Invalid argument
Nov 23 21:44:47 octopus systemd[1]: rtkit-daemon.service: main process exited, code=exited, status=225/NETWORK
Nov 23 21:44:47 octopus systemd[1]: Failed to start RealtimeKit Scheduling Policy Service.
Nov 23 21:44:47 octopus systemd[1]: Unit rtkit-daemon.service entered failed state

Steps to reproduce:

Try to use pulseaudio and KDE.

Workaround steps:

1) # chmod -x /usr/bin/pulseaudio
2) # killall -9 pulseaudio
3) # /usr/lib/rtkit/rtkit-daemon & #Surprisingly, this does *not* fail!
4) $ start-pulseaudio-x11

5) And now it works...
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Monday, 26 November 2012, 16:37 GMT
Reason for closing:  Not a bug
Comment by Andrej Podzimek (andrej) - Friday, 23 November 2012, 21:01 GMT
OK, so the workaround does *not* work proprely. Although pulseaudio runs, the sound has a latency of 2 seconds or the like.
Comment by Andrej Podzimek (andrej) - Monday, 26 November 2012, 02:49 GMT
I solved the problem. For rtkit to start up correctly, you have to have network namespaces enabled:

CONFIG_NET_NS=y

And check that the symlink from /var/run to /run is in place, or else most desktop components start crashing inexplicably, although booting and basic system services will seem to work fine.

Loading...