Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32808 - [accountsservice] 0.6.29-1 unable to login with GDM same as FS#32773

Attached to Project: Arch Linux
Opened by falke (falke) - Thursday, 22 November 2012, 17:33 GMT
Last edited by Jan Steffens (heftig) - Saturday, 01 December 2012, 09:01 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description: impossible to login in gdm


Additional info:
* package version(s) accountsservice 0.6.29.1
* config and/or log files etc.


Steps to reproduce:

hello all,

this new package seemed to solve the problem until as reinstalled the new version of cinnamon which come today 1.6.7.2

as I installed accountsservice 0.6.29.1 without the new version of cinnamon it worked

as I installed in a second time cinnamon 1.6.7.2 It didn't worked anymore.
(I have cinnamon and gnome-shell installed on my machine)

It seems to be incompatibility accountsservice <--> cinnamon

This task depends upon

Closed by  Jan Steffens (heftig)
Saturday, 01 December 2012, 09:01 GMT
Reason for closing:  Fixed
Additional comments about closing:  0.6.29-2
Comment by Ionut Biru (wonder) - Thursday, 22 November 2012, 17:37 GMT
does it work with gnome-shell?
Comment by falke (falke) - Thursday, 22 November 2012, 18:10 GMT
@ biru,

yes it works with gnome-shell

1) I first booted on gnome-shell whith gnome-shell and cinnamon 1.7.2 and accountsservice 0.6.29-1 installed :

i had the same problem

2) then I uninstalled cinnamon 1.7.2 and I then could log in gdm as well as i did with gnome-shell and cinnamon 1.7.1 installed (the previous version as yesterday) and the new version of accountsservice 0.6.29-1 before cinnamon was updated to 1.7.2
Comment by falke (falke) - Thursday, 22 November 2012, 19:33 GMT
can someone pass my task in critical status ? I can't change it yet
Comment by Ionut Biru (wonder) - Thursday, 22 November 2012, 19:39 GMT
upstream is at https://bugs.freedesktop.org/show_bug.cgi?id=57343

the severity of the taks doesn't matter since we are waiting for upstream to deal with this issue.
Comment by Laurent PERRUCHE (konuro) - Saturday, 24 November 2012, 19:13 GMT
Hello, I update accountsservice 0.6.25-1 to 0.6.29-1 and after reboot, gdm no start.
this is the log :
Nov 24 17:12:28 archbox dbus-daemon[208]: dbus[208]: [system] Rejected send message, 1 matched rules; type="method_call", send
Nov 24 17:12:28 archbox dbus[208]: [system] Rejected send message, 1 matched rules; type="method_call", sender=":1.18" (uid=0
Nov 24 17:12:29 archbox gdm-simple-slave[2494]: WARNING: Failed to give slave programs access to the display. Trying to procee
Nov 24 17:12:30 archbox dbus-daemon[208]: dbus[208]: [system] Activating via systemd: service name='org.freedesktop.Accounts'
Nov 24 17:12:30 archbox dbus[208]: [system] Activating via systemd: service name='org.freedesktop.Accounts' unit='accounts-dae
Nov 24 17:12:30 archbox systemd[1]: Starting Accounts Service...
Nov 24 17:12:30 archbox accounts-daemon[2510]: started daemon version 0.6.29
Nov 24 17:12:30 archbox dbus-daemon[208]: dbus[208]: [system] Successfully activated service 'org.freedesktop.Accounts'
Nov 24 17:12:30 archbox dbus[208]: [system] Successfully activated service 'org.freedesktop.Accounts'
Nov 24 17:12:30 archbox systemd[1]: Started Accounts Service.
Nov 24 17:12:30 archbox accounts-daemon[2510]: (accounts-daemon:2510): GLib-GObject-WARNING **: g_object_set_valist: object cl
Nov 24 17:12:30 archbox kernel: accounts-daemon[2510]: segfault at 50ae18c0 ip b72e97b6 sp bf8d6b88 error 4 in libc-2.16.so[b7
Nov 24 17:12:30 archbox systemd[1]: accounts-daemon.service: main process exited, code=killed, status=11/SEGV
Nov 24 17:12:30 archbox systemd[1]: Unit accounts-daemon.service entered failed state
Nov 24 17:12:30 archbox dbus-daemon[208]: dbus[208]: [system] Activating via systemd: service name='org.freedesktop.Accounts'
Nov 24 17:12:30 archbox dbus[208]: [system] Activating via systemd: service name='org.freedesktop.Accounts' unit='accounts-dae
Nov 24 17:12:30 archbox systemd[1]: Starting Accounts Service...
Nov 24 17:12:30 archbox accounts-daemon[2515]: started daemon version 0.6.29
Nov 24 17:12:30 archbox dbus-daemon[208]: dbus[208]: [system] Successfully activated service 'org.freedesktop.Accounts'
Nov 24 17:12:30 archbox dbus[208]: [system] Successfully activated service 'org.freedesktop.Accounts'
Nov 24 17:12:30 archbox systemd[1]: Started Accounts Service.
Nov 24 17:12:30 archbox accounts-daemon[2515]: (accounts-daemon:2515): GLib-GObject-WARNING **: g_object_set_valist: object cl
Nov 24 17:12:30 archbox systemd[1]: accounts-daemon.service: main process exited, code=killed, status=11/SEGV
Nov 24 17:12:30 archbox kernel: accounts-daemon[2515]: segfault at 50ae18c0 ip b73b57b6 sp bfee3ed8 error 4 in libc-2.16.so[b7


My screen is black. Only the mouse runs.
I downgrade accountsservice 0.6.25-1, GNOME runs again.
Comment by Krzysztof Miernik (kmiernik) - Sunday, 25 November 2012, 11:53 GMT
I confirm the same behaviour on my machine:
accounts-daemon[1220]: segfault at 50afca00 ip b73c5b16 sp bffd97a8 error 4 in libc-2.16.so[b727d000+1a4000]

also had to downgrade to 0.6.25.

It has nothing to do with cinammon.
Comment by Martin Sand (sandstorm) - Sunday, 25 November 2012, 17:24 GMT
I had the same problem, segfaults in accounts-daemon. Downgrading to 0.6.25 worked! Without the package in cache I would not be able to work. Dependencies to other packages as in the original bug are not known.
Comment by Timo Saarinen (timosa) - Sunday, 25 November 2012, 20:20 GMT
I had this same problem too, but downgrading to 0.6.25-1 (from 0.6.29) helped. If it matters, I'm using GDM + Gnome Shell.

https://bbs.archlinux.org/viewtopic.php?id=153579
Comment by Anton (anthonio) - Monday, 26 November 2012, 02:10 GMT
Nov 26 10:37:26 admin kernel: accounts-daemon[671]: segfault at 5049bc70 ip b7387800 sp bff75768 error 4 in libc-2.16.so[b72f3000+1a4000]

This problem appears when I add in /etc/nsswitch.conf for passwd "winbind"
p.s. lightdm user
Comment by Udo Müller (i18nde) - Friday, 30 November 2012, 23:03 GMT
Same here. Intel video card, gdm and Gnome 3.6. Slim works just fine.
Seams to be a problem of i686, at another ADM 64 computer its works without any problems.
Comment by Jan Steffens (heftig) - Friday, 30 November 2012, 23:11 GMT
Please try to get a proper backtrace with a debug-compiled accountsservice.
https://wiki.archlinux.org/index.php/Debug_-_Getting_Traces
Comment by Greg (dolby) - Saturday, 01 December 2012, 02:21 GMT
I dont think the problem is the architecture cause i686 runs fine here.
Comment by Ionut Biru (wonder) - Saturday, 01 December 2012, 08:53 GMT
Jan, this commit should fix this issue http://cgit.freedesktop.org/accountsservice/commit/?id=4d5166d1833e42d81b854374aa6e73f83a67a70e
Please package it since I do not have access to my key right now.

Loading...