Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#32770 - file conflict check ignore packages removed due conflicts

Attached to Project: Pacman
Opened by Allan McRae (Allan) - Tuesday, 20 November 2012, 15:54 GMT
Last edited by Allan McRae (Allan) - Friday, 12 July 2013, 21:53 GMT
Task Type Bug Report
Category General
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 4.0.3
Due in Version 4.2.0
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

package "p1" is installed and has files /foo/bar and /foo/baz

package "p2" conflicts/replaces package "p1" and has _file_ /foo


pacman -U "p2" ask to remove "p1" for the package conflict but then aborts because /foo is found in the filesystem.
This task depends upon

Closed by  Allan McRae (Allan)
Friday, 12 July 2013, 21:53 GMT
Reason for closing:  Fixed
Additional comments about closing:  git commit cbbd3781
Comment by Andrew Gregory (andrewgregory) - Saturday, 13 April 2013, 04:57 GMT
This is fixed on my no-symlinks branch, which I'll submit soon if nobody objects on the mailing list to removing symlink support.

Loading...