Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#32765 - [pacman] makepkg failing to complete downloading from bitbucket

Attached to Project: Pacman
Opened by Nikos Theodorou (GordonGR) - Monday, 19 November 2012, 15:36 GMT
Last edited by Allan McRae (Allan) - Friday, 04 January 2013, 13:22 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Dan McGee (toofishes)
Dave Reisner (falconindy)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Fully described here:
https://mailman.archlinux.org/pipermail/aur-general/2012-November/021020.html

The poster in [1] had reported the issue days ago, but I couldn't reproduce. I reproduced it yesterday (pacman 4.0.3-4), sent the message to aur-general. Today I updated to pacman 4.0.3-5 and saw the issue remains, so I thought I'd file a bug report.

Thanks in advance.

This task depends upon

Closed by  Allan McRae (Allan)
Friday, 04 January 2013, 13:22 GMT
Reason for closing:  Upstream
Additional comments about closing:  Looks like a website issue.
Comment by Dave Reisner (falconindy) - Monday, 19 November 2012, 18:59 GMT
flyspray will surely mangle my paste below, but I can't reproduce this and there's not nearly enough information in this bug report to understand the conditions that might make it fail.

$ makepkg -o
==> Making package: kokua-bin 3.4.1-2 (Mon Nov 19 13:58:43 EST 2012)
==> Retrieving Sources...
-> Downloading Kokua-3.4.1-Linux32.tar.bz2...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 184 100 184 0 0 3048 0 --:--:-- --:--:-- --:--:-- 6133
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
100 47.6M 100 47.6M 0 0 46.2M 0 0:00:01 0:00:01 --:--:-- 91.1M
-> Found kokua.desktop
-> Found kokua.launcher
-> Found donotregister.patch
==> Validating source files with md5sums...
Kokua-3.4.1-Linux32.tar.bz2 ... Passed
kokua.desktop ... Passed
kokua.launcher ... Passed
donotregister.patch ... Passed
Comment by Nikos Theodorou (GordonGR) - Monday, 19 November 2012, 19:12 GMT
Right, if you use makepkg -o that is true. But with plain makepkg it doesn't:
nikos@Russell:~/AUR/READY/kokua-bin$ LANG=C makepkg
==> Making package: kokua-bin 3.4.1-3 (Mon Nov 19 21:07:05 EET 2012)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving Sources...
-> Downloading Kokua-3.4.1-Linux64.tar.bz2...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 184 100 184 0 0 358 0 --:--:-- --:--:-- --:--:-- 814
0 0 0 0 0 0 0 0 --:--:-- 0:00:01 --:--:-- 0
100 53.7M 100 53.7M 0 0 599k 0 0:01:31 0:01:31 --:--:-- 811k
==> ERROR: Failure while downloading Kokua-3.4.1-Linux64.tar.bz2
Aborting...
Comment by Dave Reisner (falconindy) - Monday, 19 November 2012, 19:14 GMT
I can't possibly see how -o would cause this to not fail. It still downloads and validates the tarball which means successfully finding it on the FS. Sure enough, I still can't replicate it.

bash -x makepkg |& tee log

post the logfile
Comment by Nikos Theodorou (GordonGR) - Monday, 19 November 2012, 19:21 GMT
Here you are.
   log (30.1 KiB)
Comment by Dave Reisner (falconindy) - Monday, 19 November 2012, 19:40 GMT
So curl exits 141, which means it's getting a SIGPIPE from somewhere. I'm inclined to believe it comes from bitbucket.
Comment by Allan McRae (Allan) - Monday, 19 November 2012, 23:49 GMT
I agree. If makepkg "fails" on a single site, it is not going to be makepkg's fault.
Comment by Nikos Theodorou (GordonGR) - Tuesday, 20 November 2012, 13:00 GMT
All right. In that case I'll put a noextract and do it by hand afterwards, until bitbucket resolves their issue. Thanks for looking into this.
Comment by Allan McRae (Allan) - Tuesday, 20 November 2012, 13:02 GMT
Huh - how is that going to fix a failed download?
Comment by Nikos Theodorou (GordonGR) - Tuesday, 20 November 2012, 13:16 GMT
It doesn't fail; makepkg fails to understand the download has completed and doesn't mark it as completed; doesn't remove the .part suffix, and because there is no more data to download, it declares it failed, but all the data is there.

Loading...