Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32761 - Expired Credentials on 2-Step Google Accounts after shell upgrade.

Attached to Project: Arch Linux
Opened by Nathan Bass (IngCr3at1on) - Monday, 19 November 2012, 08:10 GMT
Last edited by Ionut Biru (wonder) - Monday, 19 November 2012, 18:49 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
Unable to login to 2-Step Verification Google Accounts via 'Online Accounts'

Upon upgrade from gnome-shell and empathy 3.6.1-3 to 3.6.2 and reboot authentication to Google was lost.

Tried adding the authentication information back in; process completes fine but the account still lists as having expired credentials.
Removed account and added back in; account creates properly (confirmed application specific PW used by Key-Ring is authorized on Google's end) but still lists expired credentials (same with reboot).
Tried both options multiple times.

Additional info:
* 3.6.2-1 (Gnome-Shell; possibly related to Empathy as this cannot login/connect either)
This task depends upon

Closed by  Ionut Biru (wonder)
Monday, 19 November 2012, 18:49 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#32668 
Comment by Nathan Bass (IngCr3at1on) - Monday, 19 November 2012, 08:17 GMT
On second thought (I should have added this initially) this may be related to Gnome-Keyring 3.6.2-1 (rather than shell or empathy) as it also updated.
Comment by Phil Condreay (astex) - Monday, 19 November 2012, 08:35 GMT
This is a solved bug in gnome-online-accounts (https://bugzilla.gnome.org/show_bug.cgi?id=681727). For a temporary work-around, log in using a different DE and delete the account from within empathy.
Comment by Ionut Biru (wonder) - Monday, 19 November 2012, 10:40 GMT
g-o-a doesn't support 2-step authentication:
https://bugzilla.gnome.org/show_bug.cgi?id=688364#c2
Comment by Nathan Bass (IngCr3at1on) - Monday, 19 November 2012, 18:48 GMT
Alright seems I opened a bit of a redundant Task anyway (I searched but somehow missed this) : https://bugs.archlinux.org/task/32668 (that's related to the GOA bug listed by Wonder above).

I am annoyed by the fact that this did not occur in 3.6.1 as the other bugs would imply it should have manifested in all versions of 3.6 so I'm a little puzzled as to what broke it now (either ways seems I'm SOL for now).

Thanks for the concern (I'll add to the bugzilla task instead); sorry again for the repeat task.

Loading...