Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32752 - [mplayer2] Linked to libicuuc.so.49 while libicuuc.so.50 is now packaged.

Attached to Project: Community Packages
Opened by Benpro (benpro) - Sunday, 18 November 2012, 15:30 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Sunday, 18 November 2012, 15:44 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Bartłomiej Piotrowski (Barthalion)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The package is linked to libicuuc.so.49 but it is now (icu updated at 2012-11-18) libicuuc.so.50

Additional info:

* package version(s)
mplayer2 : 20120729-2
icu: 50.1-2

* config and/or log files etc.
$ mplayer
mplayer: error while loading shared libraries: libicuuc.so.49: cannot open shared object file: No such file or directory
$ ldd /usr/bin/mplayer
libicuuc.so.49 => not found

Steps to reproduce:
Have icu 50 installed on the system.
This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Sunday, 18 November 2012, 15:44 GMT
Reason for closing:  Not a bug
Comment by Dave Reisner (falconindy) - Sunday, 18 November 2012, 15:38 GMT
mplayer2 doesn't link to icu. You're looking at the fully resolved dependencies.

LD_DEBUG=files mplayer

Find out what needs icu.
Comment by Benpro (benpro) - Sunday, 18 November 2012, 15:43 GMT
Sorry for the noise :( !

25686: file=libicuuc.so.49 [0]; needed by /usr/local/lib/libass.so.4 [0]

Seems due to libass and a mess in my system.

Loading...