Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32708 - [apache] issues starting using systemctl

Attached to Project: Arch Linux
Opened by Victor Aurélio (hotvic) - Friday, 16 November 2012, 15:51 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Saturday, 17 November 2012, 21:31 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture i686
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
trying to start apache from systemctl and it's fail.
but trying to start using apachectl it's started.

Additional info:
* package version(s)

systemd: 195-2
apache: 2.2.23-1

* config and/or log files etc.

# systemctl start httpd:
Job for httpd.service failed. See 'systemctl status httpd.service' and 'journalctl -n' for details.
---------------------------------------------------------------------------------------------------------------------
# journalctl -n
Nov 16 12:20:53 Victor-Arch_Linux systemd[1]: Starting Apache Web Server...
Nov 16 12:20:54 Victor-Arch_Linux systemd[1]: PID file /run/httpd/httpd.pid not readable (yet?) after start.
Nov 16 12:20:54 Victor-Arch_Linux systemd[1]: Failed to start Apache Web Server.
Nov 16 12:20:54 Victor-Arch_Linux systemd[1]: Unit httpd.service entered failed state
---------------------------------------------------------------------------------------------------------------------
Start using apachectl:
# /usr/sbin/apachectl start
[no output]

Steps to reproduce:

1. - Start Apache using systemctl
# systemctl start httpd

2. - Start Apache using apachectl

# /usr/sbin/apachectl start
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Saturday, 17 November 2012, 21:31 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Please re-open if needed (is a true bug). Ask in forums for support.
Comment by phanisvara das (phani00) - Friday, 16 November 2012, 16:20 GMT
for me this works without problem; i'm using the same version of systemd & apache as you, but on a 64bit system. some problem with permissions in /var/run/httpd perhaps?
Comment by Victor Aurélio (hotvic) - Friday, 16 November 2012, 20:30 GMT
$ stat /run/httpd/
File: “/run/httpd/”
Size: 40 Blocks: 0 IO Block: 4096 diretório
Device: eh/14d Inode: 868491 Links: 2
Access: (0755/drwxr-xr-x) Uid: ( 0/ root) Gid: ( 0/ root)
Comment by Adam Bevelhymer (thebeav) - Saturday, 17 November 2012, 19:52 GMT
This works no problem for me as well on a 32bit system. Same version of apache and systemd (systemd 195-2, apache 2.2.23-1)

Loading...