Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32698 - [libreoffice-common] Read-only filesystem prevents spadmin to work properly

Attached to Project: Arch Linux
Opened by Guillaume R. (mayweed) - Friday, 16 November 2012, 08:19 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 10 March 2013, 07:46 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture i686
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Description:
When I tried to set up the default configuration of my printer, so that langugage type sticks at Postscript, I can't run spadmin to do it. It says: "No printers can be installed, because the file system is read-only."

Additional info:
* package version(s)
LibreOffice 3.6.3-1
* config and/or log files etc.


Steps to reproduce:
1- Install LibreOffice
2- Try to run spadmin as root
3- A pop-up window will appear with the error message
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 10 March 2013, 07:46 GMT
Reason for closing:  Fixed
Additional comments about closing:  4.0.1-2
Comment by Guillaume R. (mayweed) - Friday, 16 November 2012, 08:21 GMT Comment by edenyard (edenyard) - Saturday, 08 December 2012, 13:40 GMT
Same problem on Libreoffice 3.6.4.3 on x86_64 machine.
Comment by Andreas Radke (AndyRTR) - Friday, 28 December 2012, 13:21 GMT
Can you find out what file can't be written? Maybe use strace.
Comment by edenyard (edenyard) - Saturday, 29 December 2012, 09:38 GMT
Please can you indicate what 'strace' is all about and how I would use it as you suggest to find out which file can't be written to?
Comment by Guillaume R. (mayweed) - Saturday, 05 January 2013, 08:34 GMT
For clarity purpose I trace the three main syscall (read/write/open). Cf file attached.
I copy/paste because 2>&1 weirdly did not work with strace output.

Wrt the file:
--> I got a printers.tdb in /var/lib/samba/printing
--> I do have an open cups socket:
[raimondeaug@hades cups]$ file /var/run/cups/cups.sock
/var/run/cups/cups.sock: socket
--> I do not have a .Xdefaults, neither in root directory nor in user directory
Comment by pierre (pierremx) - Friday, 18 January 2013, 11:32 GMT
Same problem, with an up to date system : pop-up window with the error message :(
Comment by Vincent Van Houtte (zenlord) - Tuesday, 05 March 2013, 18:31 GMT
Same problem. Some googling has delivered these results:
* https://issues.apache.org/ooo/show_bug.cgi?id=3909#c5 (seems to be connected to a psprint.conf-file)

Upstream bugreport: https://bugs.freedesktop.org/show_bug.cgi?id=55962
Comment by Mathias Lang (sublunar) - Thursday, 07 March 2013, 16:02 GMT
Same problem here, but also a solution!
Under https://bugs.freedesktop.org/show_bug.cgi?id=55962#c16 a FreeBSD-guy proposed to to compile with the "--with-ppds" option. I cross-checked the gentoo-ebuild (http://data.gpo.zugaina.org/gentoo/app-office/libreoffice/libreoffice-4.0.0.3.ebuild) - they simply omit the "--without-ppds" option in the ebuild.
So just comment out the "--without-ppds" line in PKGBUILD and recompile libreoffice-common and the read-only filesystem error is gone!
Comment by Andreas Radke (AndyRTR) - Saturday, 09 March 2013, 07:59 GMT
I can't reproduce this error anymore in 4.0.1 here. Can you confirm it working? I haven't changed anything in the build process...
Comment by Jonathan Dlouhy (oboedad55) - Saturday, 09 March 2013, 08:12 GMT
I just upgraded to LO 4.0.1 and the problem persists as user and as root.
Comment by Andreas Radke (AndyRTR) - Saturday, 09 March 2013, 20:33 GMT
Please check 4.0.1-2 - I've now removed --without-ppds.
Comment by Jonathan Dlouhy (oboedad55) - Saturday, 09 March 2013, 21:51 GMT
Thanks Andreas, that fixed it.
Comment by Mathias Lang (sublunar) - Sunday, 10 March 2013, 00:31 GMT
Yes, works!

Loading...