Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#32649 - {wiki}{forum} registration question is broken during the first week of the year.

Attached to Project: Arch Linux
Opened by Karol Błażewicz (karol) - Wednesday, 14 November 2012, 14:49 GMT
Last edited by Pierre Schmitz (Pierre) - Saturday, 02 November 2013, 23:07 GMT
Task Type Bug Report
Category Web Sites
Status Closed
Assigned To Pierre Schmitz (Pierre)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No


The current registration question for the forums is
What is the output of "date -u +%W$(uname)|sha256sum|sed 's/\W//g'"?
and for the wiki
What is the output of "date -u +%W`uname`|sha256sum|sed 's/\W//g'"?
(this makes the wiki csh-friendly).

The code breaks in the first week of the year.
It has been suggested to change the question from using 00`uname` to 52`uname`

If there are no downsides to using `uname` instead of $(uname), we could make both registration questions identical.
This task depends upon

Closed by  Pierre Schmitz (Pierre)
Saturday, 02 November 2013, 23:07 GMT
Reason for closing:  Not a bug
Comment by Profpatsch (Profpatsch) - Wednesday, 02 January 2013, 23:48 GMT
Yep, and now it’s the first week of the year and I want to log in.
It sure is a fancy way of keeping Windows guys and spambots out (The same? Who knows…) but not if it doesn’t work.
Comment by dom0 (dom0) - Thursday, 03 January 2013, 22:56 GMT
It'd probably a better idea to use a bit... simpler question. For example:

date +%Y`uname`|sha256sum|sed 's/\W//g'
Comment by Profpatsch (Profpatsch) - Friday, 04 January 2013, 12:16 GMT
+1 for simpler. :D
But yeah, would only break every ten or hundred or thousand years. :D
Comment by Jonathan Chan (jyc) - Monday, 07 January 2013, 02:31 GMT
This really should be fixed. Tried to register for the forums today, and it was very frustrating to be told that my answer was wrong until I ran echo 02$(uname)|sha256sum|sed 's/\W//g' instead...

Or perhaps I am some sort of spambot?
Comment by Karol Błażewicz (karol) - Monday, 14 January 2013, 09:12 GMT
The question has been changed to
What is the output of "date -u +%V$(uname)|sha256sum|sed 's/\W//g'"?

If using 'date -u +%V' instead of '%W' fixes the issue with registering in the first week of the year and no one cares about being csh-friendly, we can close this report.