Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32631 - (xfce4) terminal distorded

Attached to Project: Community Packages
Opened by Sebastian Benvenuti (santodelaespada) - Tuesday, 13 November 2012, 16:59 GMT
Last edited by Alexander F. Rødseth (xyproto) - Wednesday, 14 November 2012, 19:31 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The xfce4 terminal changes characters randomly but consistently.
For example: all "/" shows as "+", even when i type them.
the first run of the terminal usually works fine. But after closing it and reopening a new instance it's distorted. When closing/opening again the disorder changes. It gets worse everytime.


Additional info:
package version(s): terminal 0.4.8-2 (x86_64)
Does not affect terminator or the tty consoles.
Changing font fixes the issue on the running instance, when closing and opening a new one it reappears.
I did a full clamscan antivirus scan, no infected files were found.

Steps to reproduce:
1. Open xfce4 terminal, do a "ls /" - all good (good.png)
2. close all instances of terminal
3. open new instance of terminal - random disorder
4. do "ls /" to get output - very disordered (bad1.png)
5. repeat 2,3,4 - worse (bad2.png)
5. repeat 5 - worse (bad3.png)

from /var/log/pacman.log
[2012-10-17 11:15] installed terminal (0.4.8-2)
Witch makes me think the problem is in one of the dependencies.
This task depends upon

Closed by  Alexander F. Rødseth (xyproto)
Wednesday, 14 November 2012, 19:31 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Duplicate of  FS#32612  (and caused by upstream/nvidia blob)
Comment by Sebastian Benvenuti (santodelaespada) - Tuesday, 13 November 2012, 17:18 GMT
screenshots
   good.png (30.1 KiB)
   bad1.png (11.6 KiB)
   bad2.png (28.9 KiB)
   bad3.png (30.4 KiB)
Comment by Greg (dolby) - Tuesday, 13 November 2012, 19:57 GMT
Do you have any settings from the advanced tab http://docs.xfce.org/_media/apps/terminal/terminal-preferences-advanced.png
in terminal's preferences changed?
Like changing the $TERM value to a 256 colored terminal?
That isn't recommended.
Comment by Sebastian Benvenuti (santodelaespada) - Wednesday, 14 November 2012, 00:42 GMT
OK, this is going south.
Greg, I checked the prefs, and they look the same as the one in the image you linked.
I only change: Don't show menu bar on new windows - BG color to black - Tango Colorset - BG transparency to 90%
my prompt is colored by the bashrc file, as shown on the wiki.


While closing/opening instances of terminal, I noticed the glitch extends to the right click menu (over the terminal).
Also, when opening xfce4-screenshooter, the same happens on the gtk window.
Now terminator is also affected.
Seems like is something wrong with my system.
Can anyone reproduce this?
Comment by Sebastian Benvenuti (santodelaespada) - Wednesday, 14 November 2012, 00:45 GMT
pacman output looks fine on the same window the glitch is present, until the slash in "[Y/n]" on the confirmation prompt.
I've retained nvidia drivers updates since 304.60-1 is the last one to support my Nvidia 7025 on board GPU.
Comment by Greg (dolby) - Wednesday, 14 November 2012, 00:59 GMT
Ah! The nvida blob.
Check  FS#32612 
Comment by Sebastian Benvenuti (santodelaespada) - Wednesday, 14 November 2012, 15:25 GMT
F You Nvidia!
Thank you Greg. It was driving me crazy.
I switched to nouveau and all works fine.
Seems like I need a new gpu to play urbanterror.

Loading...