Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32612 - [xorg-server-common] Pixman update isn't that great

Attached to Project: Arch Linux
Opened by Marcin Rzeźnicki (mrzeznicki) - Sunday, 11 November 2012, 23:31 GMT
Last edited by Andreas Radke (AndyRTR) - Saturday, 08 December 2012, 09:15 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 76
Private No

Details

Description:

After getting the latest and greatest pixman (and 1.13.0-4 xorg) I am left with X crashing everytime I log into KDE. I can see my desktop for a few seconds and then boom.

Additional info:

Bug concerns xorg-server-common 1.13.0-4 (reverting to 1.13.0-3 fixes the issue)

The message I dug out from logs is:

[ 68.839] (EE)
[ 68.839] (EE) Backtrace:
[ 68.839] (EE) 0: /usr/bin/X (xorg_backtrace+0x36) [0x58a326]
[ 68.839] (EE) 1: /usr/bin/X (0x400000+0x18e179) [0x58e179]
[ 68.839] (EE) 2: /usr/lib/libpthread.so.0 (0x7fed98e4c000+0xf1a0) [0x7fed98e5b1a0]
[ 68.839] (EE) 3: /usr/lib/libpixman-1.so.0 (0x7fed989a8000+0x82990) [0x7fed98a2a990]
[ 68.839] (EE) 4: /usr/lib/libpixman-1.so.0 (0x7fed989a8000+0x82b86) [0x7fed98a2ab86]
[ 68.839] (EE) 5: /usr/lib/libpixman-1.so.0 (pixman_image_composite32+0x459) [0x7fed989b3349]
[ 68.839] (EE) 6: /usr/lib/libpixman-1.so.0 (pixman_glyph_cache_insert+0x109) [0x7fed989f66f9]
[ 68.839] (EE) 7: /usr/lib/xorg/modules/libfb.so (0x7fed95619000+0x19b6c) [0x7fed95632b6c]
[ 68.839] (EE) 8: /usr/bin/X (0x400000+0x1143d1) [0x5143d1]
[ 68.839] (EE) 9: /usr/bin/X (0x400000+0x10d5d6) [0x50d5d6]
[ 68.839] (EE) 10: /usr/bin/X (0x400000+0x37e61) [0x437e61]
[ 68.839] (EE) 11: /usr/bin/X (0x400000+0x2696a) [0x42696a]
[ 68.839] (EE) 12: /usr/lib/libc.so.6 (__libc_start_main+0xf5) [0x7fed97ada725]
[ 68.839] (EE) 13: /usr/bin/X (0x400000+0x26cad) [0x426cad]
[ 68.839] (EE)
[ 68.839] (EE) Segmentation fault at address 0xffefffff
[ 68.839]
Fatal server error:
[ 68.839] Caught signal 11 (Segmentation fault). Server aborting
[ 68.839]
[ 68.839] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.


Steps to reproduce:

Log into KDE, after few seconds X server crashes
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Saturday, 08 December 2012, 09:15 GMT
Reason for closing:  Fixed
Additional comments about closing:  Nvidia is aware of it, VMware probably not. We will say welcome again to this bug trigger when 1.14 will be released. Glyph caching is now disabled again until then.
Comment by Greg (dolby) - Sunday, 11 November 2012, 23:38 GMT
Works great here!
What xorg driver are you using?
Comment by Marcin Rzeźnicki (mrzeznicki) - Sunday, 11 November 2012, 23:48 GMT
vmware's, my arch is a vmware guest. I am attaching Xorg logs I grabbed when it was crashing
   Xorg.log (60.9 KiB)
Comment by Michael Koloberdin (mkoloberdin) - Sunday, 11 November 2012, 23:51 GMT
Same here on VMWware, and there actually seem to be two problems, not just one. (see  FS#32613 )
On real hardware (a netbook with intel GPU) it works fine for me though.
Comment by Philipp Claßen (PhCl) - Sunday, 11 November 2012, 23:53 GMT
Same here, too. Arch on VMWare.
Comment by Marcin Rzeźnicki (mrzeznicki) - Sunday, 11 November 2012, 23:57 GMT
Ooops, I overlooked vmmouse problem. Wonder if that's the culprit?
Comment by Philipp Claßen (PhCl) - Monday, 12 November 2012, 00:42 GMT
As a workaround, downgrading both xorg-server and xorg-server-common is a temporary fix for the problem:

cd /var/cache/pacman/pkg
pacman -U xorg-server-1.13.0-3-x86_64.pkg.tar.xz xorg-server-common-1.13.0-3-x86_64.pkg.tar.xz
Comment by James Chew (j4m35) - Monday, 12 November 2012, 08:41 GMT
I get the same problem too. Arch guest on VMWare. Philipp Claßen's workaround does the trick.
Comment by Natrio (natrio) - Monday, 12 November 2012, 09:28 GMT
It's not only on vmware driver.
I have a massive font corruption on nvidia driver (both 304xx and 173xx) in xfce and firefox.
Comment by Charles (ecdahl) - Monday, 12 November 2012, 09:38 GMT
I got the same segmentation fault yesterday on a fresh install of Arch, on real hardware (not as a VMWare guest).

Update: Sorry guys, it seems the segfault I got was related to the intel driver and sna. Once I switched back to uxa, X has been stable.
Comment by Jan de Groot (JGC) - Monday, 12 November 2012, 10:35 GMT
What other drivers than vmware are causing segfaults at this moment?
Comment by Christian (Watnuss) - Monday, 12 November 2012, 16:51 GMT
I attached my Xorg log file from the latest crash (Xorg.0.log.old). I am running Arch as a VMWare guest and cannot start the terminal/firefox or any Xorg program with the newest x server. My logfile also says something about vmmouse. Maybe you can see something else or more than I.
Downgrading as Philipp Claßen suggested worked for me, too.
Comment by Fredrick John Berchmans (fjohnber) - Tuesday, 13 November 2012, 09:03 GMT
I am also seeing the same problem with Arch on VMWare Player.
Comment by Cedric Bellegarde (gnumdk) - Tuesday, 13 November 2012, 09:38 GMT
I think it's a bug in drivers due to new glyph cache API...

Here i've got screen font corruptions with nvidia driver but not with nouveau or intel drivers.
Comment by Natrio (natrio) - Tuesday, 13 November 2012, 09:45 GMT
It isn't a new glyph cache API, it'a s GIT UNSTABLE API VERSION, not a stable driver bug.
I don't know about WmWare, but Nvidia will never make the driver for unstable version of API.
Comment by Michael Stenzel (geekmiki) - Tuesday, 13 November 2012, 09:56 GMT
The pixman update to 0.28.0-1 causes also problems with transparency in tabs with Chromium.
See the following post: https://bbs.archlinux.org/viewtopic.php?pid=1191571

Downgrading to 0.26.2-1 solves the issue
Comment by Andreas Sonnenbichler (sonnyka) - Tuesday, 13 November 2012, 12:52 GMT
I confirm the error. Same thing here with Arch running in a VMWare Environment.
Downgrading is a work around.
Comment by Greg Day (jakh) - Tuesday, 13 November 2012, 20:50 GMT
Also confirming the error & workaround. Arch linux running VMWare Fusion 4.1.3.
Comment by Greg (dolby) - Tuesday, 13 November 2012, 20:56 GMT Comment by Jan de Groot (JGC) - Tuesday, 13 November 2012, 23:10 GMT
The patch that makes X use the pixman glyph cache doesn't change API at all, but changes what X does with glyphs. Instead of calculating the same glyphs over and over again, X uses the pixman glyph cache instead. So far the things that don't work are:
- drivers that fuck with internal X stuff, like nvidia seems to do.
- drivers that end up passing stuff to X that the new code doesn't handle correctly and causes invalid arguments passed to pixman.

Anyways, we can revert this patch and wait until we get hit by the same bug again when the next version of xorg-server will include this code from upstream, or start being constructive and debug this problem.

Comment by Natrio (natrio) - Wednesday, 14 November 2012, 05:09 GMT
Okay, it doesn't change the API, but it breaks up the old way of working with fonts in xorg.
The new behavior is typical for a new branch of xorg-server-1.14, which is the right place in the [testing], until the nvidia adapts driver, as usual.
Comment by Marcin Rzeźnicki (mrzeznicki) - Thursday, 15 November 2012, 00:51 GMT
Would someone care to comment how's this progressing?
Comment by Greg (dolby) - Thursday, 15 November 2012, 00:58 GMT
Obviously none of the affected people cares about finding the actual problem so you should probably wait for a new pixman that reverts this aka rely on someone else to do the job...
Comment by Aaron Bedra (abedra) - Thursday, 15 November 2012, 02:32 GMT
I had the same issue (VMWare Fusion). Attached is my log
Comment by Christian (Watnuss) - Thursday, 15 November 2012, 12:35 GMT
- - - Comment by Greg (dolby) - Thursday, 15 November 2012, 01:58 GMT+1: "Obviously none of the affected people cares about finding the actual problem so you should probably wait for a new pixman that reverts this aka rely on someone else to do the job..."
It's not that I am not willing to help with the problem. But I simply have no idea how I could help. What would be a task I could perform? What information is missing?
I did not have any other seg faults while the problem with X happened.
Comment by aexoxea (aexoxea) - Saturday, 17 November 2012, 08:44 GMT
New to adding information on bug reports here, so please bear with me.

I am able to replicate this crash running Arch x86_64 guest under VMWare Fusion 5.0.2 with pixman 0.28.0-1. I also have xorg-server 1.13.0-4 installed, and am using KDE/KWin/KDM 4.9.3-1. However, for me, X does not crash straight after logging in to KDE; I can log in and use most applications without any difficulty. My Arch setup is almost exclusively KDE/Qt; the few GUI applications that aren't KDE/Qt applications include:

- xterm and xclock (I left TWM and the 'default' X apps installed), which I can run fine; and
- Chromium (23.0.1271.64-1) and LibreOffice (3.6.3-1), which I can't: A few seconds after launching either of these, the display freezes, and a few seconds after that, X crashes. As a test, I also sync'd GIMP (2.8.2-1), and it shows the same behaviour.

I wanted to add this detail in case it is useful to anyone else in tracking down the exact issue (I know one of the commonalities is GTK2, but then my experience in this area is very light). Also, this _might_ already have been submitted upstream under https://bugs.freedesktop.org/show_bug.cgi?id=55882, though I will too defer to the expertise of others in this area, given that report was originally created on 11 October 2012 (and thus is maybe not recent enough to be relevant?)

EDIT 19 November 2012: Having worked with this for a few more days, I subsequently discovered the crash can be replicated through two very specific KDE actions: (1) Pulling down the "Run" panel (i.e Alt + F2) and then typing in anything, or (2) Opening the "Font Management" component under System Settings. I will update further if I discover other ways to replicate, but that seems to be it for now.

EDIT 24 November 2012: I have tested the above in an Arch x86_64 guest under VirtualBox (also on top of OS X); packages are all the same versions except for LibreOffice, which is now 3.6.3-3. I am not able to replicate the crashes. The main difference between these environments is the guest additions (open-vm-tools under VMWare vs. virtualbox-guest-modules and virtualbox-guest-utils under VirtualBox).
Comment by Philipp Claßen (PhCl) - Saturday, 17 November 2012, 16:19 GMT
I am using VMWare 8.0.4 build-744019. Host: Windows 7, Guest: Arch x86_64

Starting i3 works fine, but when I open any window (console, browser, whatever), it crashes after about 1 second. Attached is my log (ending with the identical stacktrace as in the bug report). I have also attached the ouput of "pacman -Q", so you know the exact versions of the installed packages. Hope it helps.

By the way, disabling 3D graphics acceleration in the VMWare settings makes no difference.
Comment by Gennady (Leonardo19) - Sunday, 18 November 2012, 09:48 GMT
I made this screenshot upon xorg-server upgrading. nvidia-304.64-1.
Comment by RK (keoz) - Sunday, 18 November 2012, 10:09 GMT
I have exactly the same problem, with nvidia-304xx. Weird fonts since I updated the drivers (for the versioned package of nvidia-304xx) + xorg-server, pixman. In the same upgrade there was also cairo, pango, and so on.

Card: GeForce 6600

For the moment, I solved the problem switching to nouveau.
Comment by Aapo Vienamo (tkln) - Sunday, 18 November 2012, 20:03 GMT
I have the same problem as Gennandy and RK. Just upgraded and some of the fonts are messed up in the same way. I have nvidia 8400GS and the driver used is nvidia 310.19-2.
Comment by Jagadish R (jarav) - Monday, 19 November 2012, 12:11 GMT
Weird font artifacts especially after using programs that use non-english fonts. Downgrading to xorg-server-1.13.0-3 seems to have helped. I am using Nvidia driver version 304.64. My card doesn't support the latest Nvidia driver version.
Comment by jellysheep (jellysheep) - Monday, 19 November 2012, 12:35 GMT
Here exactly the same promlems with 304.xx drivers. My card (Go 6600) isn't supported by the 310.xx drivers as well.
Downgrading to xorg-server-1.13.0-3 works as well as switching to nouveau driver (I think I'll stay with the nouveau driver).
Comment by David Runge (davezerave) - Monday, 19 November 2012, 16:53 GMT
I still have the artifacts with nvidia 310.19-2 (on a 9500G - 9400M G & 9200M GS) and xorg-server 1.13.0-4. Will revert to 1.13.0-3, too.
Hope this will get fixed soon.
Comment by Ternia (Prickle) - Monday, 19 November 2012, 18:05 GMT
Same fonts issue with nvidia 304.64 and 310.19, I'll switch to xorg-server 1.13.0-3 I guess.
Comment by Jason (Meyithi) - Friday, 23 November 2012, 21:47 GMT
Same issue with nvidia 310.19 in dwm with all GTK apps, fonts garble, ui does funny things (fading in chromium tabs).
Comment by Johan R (cleanrock) - Sunday, 25 November 2012, 07:14 GMT Comment by Marcin Rzeźnicki (mrzeznicki) - Monday, 26 November 2012, 13:00 GMT
Does the new RC version 1.13.1rc1 fix this or should we stay away from it as well?
Comment by Andreas Radke (AndyRTR) - Monday, 26 November 2012, 14:21 GMT
1.13.1rc1 also has the patch included. Feel free to use abs and disable the pixman patch. But it's better to get it fixed upstream in any way.
Comment by Johan R (cleanrock) - Monday, 26 November 2012, 15:17 GMT
Why still include a performance patch you now know is broken for nvidia users ?
Odd choice considering how many use nvidia-blob.
Comment by Dave Reisner (falconindy) - Monday, 26 November 2012, 15:28 GMT
Andreas and Jan's point is that you're going to see this bug once 1.13.1 is released, and it will no longer be Arch's "fault" that this is "broken". While I disagree that we should be holding onto this patch, the point remains that xorg-server upstream isn't going to change anything, nor is nvidia, unless someone actually makes the effort to work with them and find an actual fix.
Comment by Marcin Rzeźnicki (mrzeznicki) - Monday, 26 November 2012, 15:44 GMT
vmwgfx (or is it svga-dri?) exhibits this buggy behavior too. Who is supposed to "fix" it? oepn-vm-tools guys or Xorg guys? I am not sure who maintains the bits.
Comment by Jan de Groot (JGC) - Monday, 26 November 2012, 15:45 GMT
We'll probably release 1.13.1 without this patch. The RC in testing, besides the increased version number, is 100% identical to the version in extra, as that includes all fixes from git.

As for the patch: as Nvidia is aware of this problem now, they'll probably fix this or give information what is wrong with this. If Nvidia wasn't made aware of this problem we would see this problem again as soon as 1.14.0 was released upstream.

As for the vmware crashes: so far nobody has compiled the vmware driver and xorg-server with debug symbols to find out how NULL objects could end up in the glyph cache. This means that as soon as 1.14.0 will get released from upstream, vmware users will see crashes again.
Comment by Shara (Shara) - Monday, 26 November 2012, 21:28 GMT
Same problem, X 1.13.1 Nvidia 7300gt driver 304.xx
Comment by aleksandr (iframe) - Tuesday, 27 November 2012, 20:01 GMT
Same problem, Nvidia 7600 GT
xorg-server-common 1.13.0-4 xorg-server 1.13.0-4 nvidia-304xx 304.64-1
Comment by Dave Reisner (falconindy) - Tuesday, 27 November 2012, 20:14 GMT
Please stop posting "same problem" if you have nothing else useful to add to this bug report. Really, we know its a bug. We know who it affects.
Comment by Jan Steffens (heftig) - Saturday, 01 December 2012, 14:16 GMT
Disabling xrender might be a suitable workaround:

Section "Extensions"
Option "RENDER" "Disable"
EndSection
Comment by Ondřej Konečný (andrew9888) - Monday, 03 December 2012, 13:34 GMT
Disabling RENDER didn't help in my case. Recompilling X without the performance patch mentioned above did.
Comment by John Morris (johni) - Tuesday, 04 December 2012, 16:50 GMT
FYI, Nvidia has identified the bug causing the font corruption, and it will be fixed in future driver release:

https://devtalk.nvidia.com/default/topic/524242/linux/pixman-glyph-cache-patch
Comment by Tom (hungerfish) - Friday, 07 December 2012, 18:42 GMT
"...This means that as soon as 1.14.0 will get released from upstream, vmware users will see crashes again."
But 1.13.1 also doesn't seem work for vmware users, at least for me both 1.13.0.901-1 and 1.13.0.902-1 from testing still result in the xserver crashing.
Just to get this clear, I need to either wait for a fix in the vmware driver or build the X packages myself without said patch?
Comment by Evangelos Foutras (foutrelis) - Friday, 07 December 2012, 18:48 GMT
> Just to get this clear, I need to either wait for a fix in the vmware driver or build the X packages myself without said patch?

Yes.
Comment by Johan R (cleanrock) - Friday, 07 December 2012, 19:07 GMT
Devs, you ask us to stop posting "same problem" reports.
I ask you to respect the many users who use the "evil" nvidia blob.
Even when you knew about this problem (not only vmware) you decided to keep the "fun" performance patch.
Comment by Andreas Radke (AndyRTR) - Friday, 07 December 2012, 19:14 GMT
Nvidia is aware of it. What about Vmware?

Loading...