Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32600 - [xf86-video-ati] update from 6.14.6 to 7.0.0 unable to start X server with kdm

Attached to Project: Arch Linux
Opened by Valentino Pistis (zappa) - Sunday, 11 November 2012, 14:35 GMT
Last edited by Andreas Radke (AndyRTR) - Friday, 28 December 2012, 18:16 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

Description:
Today i upgrade the system with "pacman -Syu" and an upgrade pack for xf86-video-ati was present.
When restart the system, the X server doesn't start.
using "systemct restart kdm" nothing change.
To solve I reinstalled the previous version 6.14.6 and "systemctl restart kdm" start X server correctly.

Additional info:
Package without problems: xf86-video-ati-1:6.14.6-2-x86_64.pkg.tar.xz

pacman.log:
[2012-11-11 13:16] Running 'pacman -Syu'
[2012-11-11 13:16] synchronizing package lists
[2012-11-11 13:17] starting full system upgrade
[2012-11-11 13:18] upgraded pixman (0.26.2-1 -> 0.28.0-1)
[2012-11-11 13:18] upgraded cairo (1.12.8-1 -> 1.12.8-2)
[2012-11-11 13:18] upgraded gtk3 (3.6.1-2 -> 3.6.2-1)
[2012-11-11 13:18] upgraded libdrm (2.4.39-1 -> 2.4.40-1)
[2012-11-11 13:18] upgraded lib32-libdrm (2.4.39-1 -> 2.4.40-1)
[2012-11-11 13:18] upgraded man-pages (3.43-1 -> 3.44-1)
[2012-11-11 13:18] upgraded ruby (1.9.3_p286-1 -> 1.9.3_p327-1)
[2012-11-11 13:18] upgraded tzdata (2012h-1 -> 2012i-1)
[2012-11-11 13:18] upgraded xf86-video-ati (1:6.14.6-2 -> 1:7.0.0-1)
[2012-11-11 13:18] upgraded xorg-server-common (1.13.0-3 -> 1.13.0-4)
[2012-11-11 13:18] upgraded xorg-server (1.13.0-3 -> 1.13.0-4)

Steps to reproduce:
upgrade the system with "pacman -Syu" with package list mentioned above
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Friday, 28 December 2012, 18:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  Following the upstream report I assume the initial issue is gone now.
Comment by Mathias Anselmann (matse) - Sunday, 11 November 2012, 15:13 GMT
Same problem here, see also my forum post for my xorg.log:
https://bbs.archlinux.org/viewtopic.php?id=152720
Comment by Andreas Radke (AndyRTR) - Sunday, 11 November 2012, 15:37 GMT
Make sure you run in KMS mode. UMS isn't supported anymore. If you're on KMS report it upstream and find a fix.
Comment by Valentino Pistis (zappa) - Sunday, 11 November 2012, 15:55 GMT
Thanx for your interest....
If you intended this https://wiki.archlinux.org/index.php/KMS for KMS mode, I presume that it's available because I use xf86-vide-ati and this already enable the KMS mode...if you intended other tell you please...
Comment by Mathias Anselmann (matse) - Sunday, 11 November 2012, 15:57 GMT
I'm on KMS, too and have reported the bug upstream:
https://bugs.freedesktop.org/show_bug.cgi?id=56986
Comment by Andreas Radke (AndyRTR) - Sunday, 11 November 2012, 16:17 GMT
CC'ed to the upstream bug.
Comment by Mike Cloaked (mcloaked) - Sunday, 11 November 2012, 21:01 GMT
It is working fine for me on my Dell 610 laptop with:

lspci -nn | grep VGA
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI RV370 [Mobility Radeon X300] [1002:5460]

lsmod|grep radeon
radeon 788284 2
ttm 46763 1 radeon
drm_kms_helper 28941 1 radeon
drm 180042 4 ttm,drm_kms_helper,radeon
i2c_algo_bit 4583 1 radeon
i2c_core 16943 4 drm,drm_kms_helper,i2c_algo_bit,radeon

pacman -Q xorg-server xf86-video-ati
xorg-server 1.13.0-4
xf86-video-ati 1:7.0.0-1

I use kdm and kde runs fine with today's updates.

So I guess issue this must be specific to the original poster's graphics chipset or particular setup?
Comment by Mike Cloaked (mcloaked) - Sunday, 11 November 2012, 21:46 GMT
Might be useful for anyone having the problem to say which graphics card they are using?
Comment by Mike Cloaked (mcloaked) - Sunday, 11 November 2012, 21:49 GMT
One thing for my system is that I am using late kms - which is the default - I have not tried early kms - do the others having the problem use early or late kms?
Comment by wudlig bauer (wudligbauer) - Sunday, 11 November 2012, 22:28 GMT
Mine doesn't work either - I'm on a Dell 3560 laptop - giving me exactly the same xorg.log output as posted in the first comment.
I'm on early KMS but having two graphic cards (with the Intel one beeing in-CPU I guess)

lspci -nn | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Thames XT/GL [Radeon HD 7600M Series] [1002:6840]

# pacman -Q xorg-server xf86-video-ati
xorg-server 1.13.0-4
xf86-video-ati 1:7.0.0-1

For now I stick to the Intel card (blacklisted the radeon driver) wich works fine.
Comment by Dario (GrandFunk) - Wednesday, 14 November 2012, 15:03 GMT
mine doesn' work either

lspci -nn | grep VGA
00:01.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI BeaverCreek [Radeon HD 6520G] [1002:9647]
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Whistler [AMD Radeon HD 6600M Series] [1002:6741] (rev ff)

cat /sys/kernel/debug/vgaswitcheroo/switch
0:IGD:+:Pwr:0000:00:01.0
1:DIS: :Off:0000:01:00.0
Comment by Mike Cloaked (mcloaked) - Friday, 16 November 2012, 19:47 GMT
Does a pacman update to xf86-video-intel 2.20.13-1 help fix this issue for those that had a problem?
Comment by Mike Cloaked (mcloaked) - Friday, 16 November 2012, 19:49 GMT
Ignore me - I should have been looking for xf86-video-ati!
Comment by phanisvara das (phani00) - Friday, 16 November 2012, 20:46 GMT
"Does a pacman update to xf86-video-intel 2.20.13-1 help fix this issue for those that had a problem?"

no, for me it doesn't.
Comment by Michael Dressel (mdrslmr) - Monday, 19 November 2012, 19:06 GMT
For me downgrading xf86-video-ati (1:7.0.0-1 -> 1:6.14.6-2) helps.

My hardware is:
00:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI BeaverCreek [Mobility Radeon HD 6620G]


Comment by Guillermo Leira (gleira) - Sunday, 25 November 2012, 22:08 GMT
Same problem with

01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Rage Mobility P/M AGP 2x (rev 64)

in two laptops. Seems like old cards are loosing support... :-(

Downgrading solved the problem.
Comment by Daniel (weirddan455) - Sunday, 25 November 2012, 22:19 GMT
Not just old cards. I have a Radeon 5970 and have the same issue.
Comment by Jonas (Jojonintendo) - Monday, 26 November 2012, 09:49 GMT
Same here. Default KMS, Mobility Radeon HD 6620G, doesn't boot since latest xf86-video-ati.
Comment by Adam Reichold (adamreichold) - Saturday, 01 December 2012, 16:22 GMT
Same problem, downgrading solved it, hardware is "00:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI BeaverCreek [Radeon HD 6530D]", using early KMS.
Comment by Mathias Anselmann (matse) - Sunday, 16 December 2012, 22:04 GMT
Newest xorg-server update (1.13.1) fixes this issue for me.
Comment by Stéphane Gaudreault (stephane) - Monday, 17 December 2012, 02:22 GMT
Latest xorg-server does not fix this issue for me.
Comment by Adam Reichold (adamreichold) - Monday, 17 December 2012, 06:09 GMT
Upgrading xorg-server did not fix the issue for me as well.
Comment by phanisvara das (phani00) - Monday, 17 December 2012, 08:04 GMT
for me, on 3.7.0-1-ARCH / x86_64, updating to xorg-server 1.13.1-1, fixes the problem.
Comment by Laurent Pointecouteau (hellpe) - Monday, 17 December 2012, 15:25 GMT
I'm having the same issue since I've updated to linux 3.6.10-1 yesterday : I can't startx.
Comment by Boris Lašič (bozoleclun) - Monday, 24 December 2012, 11:23 GMT
I have a 7600M card. Downgrading the kernel to 3.6.9 solved it for me. I first downgraded the xf86-video-ati but it didn't help, so i downgraded the kernel and that proved to do the trick.
Comment by Andreas Radke (AndyRTR) - Monday, 24 December 2012, 11:29 GMT
Here are several different issues. Let's focus here on the thread starters issue introduced by new ati ddx driver. Kernel drm and Xorg-server bugs are something different.

Valentino Pistis (zappa) - is this still an issue for you? Upstream has closed its bug meanwhile. I'd like to do this as well so other issues can be separated.

Loading...