Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32597 - [r] plot creates empty plot

Attached to Project: Arch Linux
Opened by Michael Rieder (wombat) - Sunday, 11 November 2012, 11:05 GMT
Last edited by Ronald van Haren (pressh) - Friday, 08 February 2013, 07:39 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
R uses type="cairo" by default for plots, which creates only empty windows for me. Calling X11(type="Xlib") before the plot command fixes it. I have no idea why X11(type="cairo") does not work.

Additional info:
* R version 2.15.1-2
* cairo 1.12.8-2 is installed
This task depends upon

Closed by  Ronald van Haren (pressh)
Friday, 08 February 2013, 07:39 GMT
Reason for closing:  Fixed
Additional comments about closing:  2.15.2-3
Comment by Ronald van Haren (pressh) - Saturday, 17 November 2012, 09:53 GMT
what was the latest R or cairo version working (or what update broke it)?

ps. type="nbcairo" also works, "dbcairo" also is broken it seems. Resizing the window also gives you the plot that is not visible before.
Comment by Michael Rieder (wombat) - Monday, 19 November 2012, 09:48 GMT
It was a new install so I don't know when it got broken.

I can confirm your observations for "nbcairo" and "dbcairo".
Comment by Benjamin Batistic (benokit) - Wednesday, 21 November 2012, 12:05 GMT
The problem could be related to a graphic driver?
On my box with the nvidia (geforce 8600 gt) graphic card and with the nvidia driver
the default type="cairo" is working fine.
But on my laptop with the integrated intel 945GM/GMS using the i915 module I observe
the same problem. I have built the older version of R (2.14.0) from source, since I know it was working
before, but again I have faced the same problem.
Comment by Ronald van Haren (pressh) - Wednesday, 21 November 2012, 12:10 GMT
Could be, I tested it on my laptop which also ha an integrated intel card.

I'll test it on my desktop with nvidia when I get home.
Comment by Michael Rieder (wombat) - Wednesday, 21 November 2012, 22:45 GMT
mine is an ATI Radeon HD 7870 with catalyst-dkms driver.

same bug in ATI and intel drivers seems unlikely to me. what about cairo?
Comment by Milan Bouchet-Valat (nalimilan) - Sunday, 06 January 2013, 17:55 GMT
I filed a bug upstream at https://bugs.freedesktop.org/show_bug.cgi?id=59085

I discovered that the problem does not appear with Cairo 1.10.2, but is present in Cairo 1.12.4 (I could not test other versions). Would somebody here be able to test more versions between these two to find out when the bug was introduced?

Fedora bug is here: https://bugzilla.redhat.com/show_bug.cgi?id=891983
Comment by Milan Bouchet-Valat (nalimilan) - Saturday, 19 January 2013, 11:04 GMT Comment by Ronald van Haren (pressh) - Saturday, 19 January 2013, 11:14 GMT
Thanks. I'll apply it as soon as I find time.
Comment by Michael Rieder (wombat) - Wednesday, 06 February 2013, 14:54 GMT
any news? ;-)
Comment by Ronald van Haren (pressh) - Wednesday, 06 February 2013, 14:55 GMT
I'll make myself find time tonight ;-) Sorry for the long wait.

Loading...