Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32593 - [libpulse] move /usr/bin/padsp from pulseaudio to libpulse

Attached to Project: Arch Linux
Opened by Ezekiel Sulastin (ZekeSulastin) - Sunday, 11 November 2012, 05:15 GMT
Last edited by Jan Alexander Steffens (heftig) - Monday, 12 November 2012, 01:35 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Hopefully this hasn't been asked before; a search drew a blank.

Currently, the script to wrap an OSS program with PulseAudio, /usr/bin/padsp, is in the package pulseaudio. padsp allows the wrapped program's PA stream to be sent to a remote server, like any other PA stream; pulseaudio is not required to be running for this to work. Just as libpulse allows programs like mpd to use PA streams without having all of PA installed, I think it would be beneficial for programs requiring padsp to work thus without having all of PA installed.

Also, the actual .so preloaded by padsp, /usr/lib/pulseaudio/libpulsedsp.so, is already in the package libpulse.

Thanks for your consideration!
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Monday, 12 November 2012, 01:35 GMT
Reason for closing:  Implemented
Additional comments about closing:  Implemented in trunk. Will be seen next release.

Loading...