Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32531 - [networkmanager] service complaining about missing service in logs (& gnome applet not working)

Attached to Project: Arch Linux
Opened by whoop (whoop) - Wednesday, 07 November 2012, 22:21 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Saturday, 17 November 2012, 05:23 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:NetworkManager.service is filling the log with error message. It can't really be called flooding but there are plenty of entries in there:

###journalctl excerpt ###
Nov 07 22:07:45 ARCHTEST dbus[370]: [system] Activating via systemd: service name='org.freedesktop.NetworkManager' unit='dbus-org.freedesktop.NetworkManager.service'
Nov 07 22:07:45 ARCHTEST dbus[370]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.NetworkManager.service': Unit dbus-org.freedesktop.NetworkManager.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.NetworkManager.
### end excerpt ###
cat /usr/lib/systemd/system/NetworkManager.service
[Unit]
Description=Network Manager
After=syslog.target
Wants=network.target
Before=network.target

[Service]
Type=dbus
BusName=org.freedesktop.NetworkManager
ExecStart=/usr/sbin/NetworkManager --no-daemon
# Suppress stderr to eliminate duplicated messages in syslog. NM calls openlog()
# with LOG_PERROR when run in foreground. But systemd redirects stderr to
# syslog by default, which results in logging each message twice.
StandardError=null

[Install]
WantedBy=multi-user.target
Alias=dbus-org.freedesktop.NetworkManager.service
### end cat ###

The file: dbus-org.freedesktop.NetworkManager.service does not seem to be existent

This error causes network-manager-applet to mallfunction with the following message: "The system network services are not compatible with this version"

Workaround:
ln -s /usr/lib/systemd/system/NetworManager.service /usr/lib/systemd/system/dbus-org.freedesktop.NetworkManager.service

After the link there is no more flooding of the log and gnome-networkmanager-applet is working again.

Additional info:
extra/network-manager-applet 0.9.6.4-1 [installed]
GNOME frontends to NetWorkmanager
extra/networkmanager 0.9.6.4-1 [installed]
Network Management daemon


This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Saturday, 17 November 2012, 05:23 GMT
Reason for closing:  Not a bug
Comment by Ionut Biru (wonder) - Wednesday, 07 November 2012, 22:48 GMT
you are doing it wrong.

just do systemctl enable NetworkManager and you are done.
Comment by whoop (whoop) - Wednesday, 07 November 2012, 23:36 GMT
Looks like you are right. But why is it complaining in the log if it's not running?
Maybe because gnome-networkmanager-applet requires it?

Comment by Gerardo Exequiel Pozzi (djgera) - Thursday, 08 November 2012, 01:34 GMT
The same thing happens with avahi, should enable it.  FS#31470 

Loading...