Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32508 - lxsession: lxsession-logout depends on consolekit

Attached to Project: Community Packages
Opened by Chris (snakeroot) - Wednesday, 07 November 2012, 02:33 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Sunday, 18 November 2012, 09:34 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description: lxsession-logout requires either consolekit or hal in order to have shutdown and reboot buttons.

This is reported in Arch forums at: https://bbs.archlinux.org/viewtopic.php?id=151895
LXDE upstream won't fix: http://sourceforge.net/tracker/index.php?func=detail&aid=3498002&group_id=180858&atid=894869
LXDE upstream got Fedora to restore Consolekit to theirrepositories https://admin.fedoraproject.org/updates/FEDORA-2012-4514/lxsession-0.4.6.1-3.fc17

See also: http://lxde.git.sourceforge.net/git/gitweb.cgi?p=lxde/lxsession;a=tree

Steps to reproduce: uninstall consolekit and start lxsession-logout.
This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Sunday, 18 November 2012, 09:34 GMT
Reason for closing:  Fixed
Additional comments about closing:  lxsession 0.4.6.1-3
Comment by Bartłomiej Piotrowski (Barthalion) - Wednesday, 07 November 2012, 05:43 GMT
I'm not eager to bring consolekit to our repositores again. I'll check how difficult will be adapting lxsession for systemd-login. If it'll be too difficult, I'll just drop the package.
Comment by Dave Morgan (loafer) - Wednesday, 07 November 2012, 07:56 GMT
Instead of dropping the package why not leave it as is if it can't be patched? Users can still logout and suspend. Reboot or shutdown can be achieved with systemctl.
Comment by Chris (snakeroot) - Wednesday, 07 November 2012, 13:30 GMT
There's a patch for lxsession-logout here that has lxsession-logout use systemd-logind for shutdown, reboot, hibernate and suspend while preserving availability of consolekit/hal/upower:

http://sourceforge.net/tracker/?func=detail&aid=3584348&group_id=180858&atid=894871

I apologize for having missed it when I filed the original report.

Comment by Bartłomiej Piotrowski (Barthalion) - Wednesday, 07 November 2012, 20:55 GMT
No problem, you saved a lot of my time. :)

Apparently this patch should be applied on HEAD from git, I'll adapt it to the latest stable release on the weekend.
Comment by Antonio Tozzi (rital) - Thursday, 15 November 2012, 09:05 GMT
I submitted my own implementation (not as a .diff file: just plain text, "cut-here" format) to sourceforge
it could help avoid a potential bad pointer issue
(please see also: https://sourceforge.net/tracker/?func=detail&aid=3587438&group_id=180858&atid=894871 )
Comment by Antonio Tozzi (rital) - Thursday, 15 November 2012, 12:04 GMT
here's a temporary source package
Comment by Dave Morgan (loafer) - Friday, 16 November 2012, 12:22 GMT
I tested the temporary package and everything seems to be working.
Comment by Bartłomiej Piotrowski (Barthalion) - Saturday, 17 November 2012, 16:00 GMT
I just pushed Antonio's implementation to [community-testing]. The only modification I made is merge of *.diff files to one patch file.
As I'm not heavy user of LXDE, could you test it and tell if I can move it to [community]?
Comment by Dave Morgan (loafer) - Saturday, 17 November 2012, 18:44 GMT
The version in [community-testing] does not provide any of the missing functionality. If I build it myself using Antonio's attachment it's fine. If I build the package using the PKGBUILD and patch from [community-testing] it builds but does not provide the missing functionality.
Comment by Bartłomiej Piotrowski (Barthalion) - Saturday, 17 November 2012, 19:02 GMT
Silly me, I forgot about one very important line in PKGBUILD, I definitively need more sleep. Anyway, -3 should make a difference.
Comment by Dave Morgan (loafer) - Saturday, 17 November 2012, 19:42 GMT
Thanks, -3 does make a difference. I am only in a position to test it on one PC with i686 but everything is now working here.
Comment by Chris (snakeroot) - Sunday, 18 November 2012, 00:42 GMT
Using x86_64. Works for me.
Comment by Tiago Teixeira (TigTex) - Sunday, 18 November 2012, 03:11 GMT
Also using x86_64, it seems to work fine.

Loading...