Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#32495 - [qtwebkit] certain SVG content freezes QtWebKit

Attached to Project: Arch Linux
Opened by Greg (dolby) - Tuesday, 06 November 2012, 16:48 GMT
Last edited by Andrea Scarpino (BaSh) - Wednesday, 09 January 2013, 13:54 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Currently there is a bug in qtwebkit-2.2 that will cause to go into an infinite loop. Though the bug has already been addressed upstream in the qtwebkit-2.3 branch, it is not available in the current stable 2.2 version.
Since it is not difficult for users to encounter the conditions that trigger this bug, I encourage distro packagers to apply the one liner fix I posted at http://pastebin.com/NqSrGBbb to their v2.2 packages. Note that the bug affects any application that uses qtwebkit if it encounters a specific kind of embedded SVG file. For details about this bug, see https://bugs.webkit.org/show_bug.cgi?id=97258

https://projects.kde.org/news/177
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Wednesday, 09 January 2013, 13:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  qtwebkit 2.3git20130108-1
Comment by Jakob Steltner (trurl23) - Friday, 16 November 2012, 23:14 GMT
Confirmed using qupzilla and the svg test html attached to the linked ticket.
Unfortunately current PKGBUILDs from svn/trunk and repos do not build because of missing source files / wrong links, so I can't confirm the patch right now.

Loading...