Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#32491 - [cairo] Missing buggy_gradients.patch makes cairo > 1.12.2 slow.

Attached to Project: Arch Linux
Opened by Antonio (kokoko3k) - Tuesday, 06 November 2012, 10:05 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Saturday, 17 November 2012, 13:33 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Summary and Info:
Starting from cairo 1.12.6, some gtk themes are very slow, even firefox is laggy when it has to scroll pages containing native widgets.

Steps to Reproduce:
Install and use qtcurve-gtk2 or an "heavy" gtk theme.
Install cairo >1.12.2 and scroll the gmail html version
Try the same with cairo 1.12.2 and see how smoother it is.

I tried to add the missing patch (cairo-1.10.0-buggy_gradients.patch) to cairo 1.12.8 and i've smooth scrolling again.

This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Saturday, 17 November 2012, 13:33 GMT
Reason for closing:  Won't implement
Comment by Antonio (kokoko3k) - Tuesday, 06 November 2012, 10:07 GMT
This pkgbuild works:
(google for cairo-1.10.0-buggy_gradients.patch before compiling)
Comment by Jan de Groot (JGC) - Tuesday, 06 November 2012, 10:52 GMT
Please report this to nvidia. Their driver was fixed for this a long while ago (270.41.03 marks this as fixed), so if this patch is still required, it's a bug in the nvidia driver.
Comment by Antonio (kokoko3k) - Tuesday, 06 November 2012, 12:43 GMT
I emailed to nvidia support, thanks.
Anyway i wonder if that patch has some downside for unaffected users (nouveau works well without the patch indeed).
Comment by Jan de Groot (JGC) - Thursday, 08 November 2012, 08:35 GMT
That patch disables server side gradients completely, which means that drivers that do implement it correctly won't have any benefits caused by server side gradients.
Comment by Antonio (kokoko3k) - Saturday, 10 November 2012, 17:35 GMT
Fair enough, thanks for explaining.
I'm still waiting for nvidia to answer to email and/or to the forum post.

...Meanwhile i made an aur package: